Bug 1095083 - FTB in rawhide
Summary: FTB in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: matreshka
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Pavel Zhukov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1106159 (view as bug list)
Depends On: 1095086 1109392
Blocks: F21FTBFS
TreeView+ depends on / blocked
 
Reported: 2014-05-07 06:00 UTC by Pavel Zhukov
Modified: 2014-10-11 22:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-11 22:19:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Pavel Zhukov 2014-05-07 06:00:39 UTC
Description of problem:
matreshka is failed to build in rawhide with new libgnat 4.9. 

Version-Release number of selected component (if applicable):
0.6.0

How reproducible:
100%

Additional info:
configure: creating Makefile.config
configure: creating gnat/install/matreshka_config.gpr
configure: creating gnat/matreshka_config.gpr
configure: (warning) command line argument '--build=i686-redhat-linux-gnu' is not recognized
configure: (warning) command line argument '--host=i686-redhat-linux-gnu' is not recognized
configure: (warning) command line argument '--program-prefix=' is not recognized
configure: (warning) command line argument '--disable-dependency-tracking' is not recognized
configure: (warning) command line argument '--exec-prefix=/usr' is not recognized
configure: (warning) command line argument '--sbindir=/usr/sbin' is not recognized
configure: (warning) command line argument '--sysconfdir=/etc' is not recognized
configure: (warning) command line argument '--datadir=/usr/share' is not recognized
configure: (warning) command line argument '--includedir=/usr/include' is not recognized
configure: (warning) command line argument '--libexecdir=/usr/libexec' is not recognized
configure: (warning) command line argument '--localstatedir=/var' is not recognized
configure: (warning) command line argument '--sharedstatedir=/var/lib' is not recognized
configure: (warning) command line argument '--mandir=/usr/share/man' is not recognized
configure: (warning) command line argument '--infodir=/usr/share/info' is not recognized
configure: (warning) substitution 'HAS_WORKING_MYSQL_SERVER' is not defined
+ make -j5 'GPRBUILD_FLAGS=-cargs -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -gnatn -gnat-p -gnatVd -gnatwn -gnatyN -largs -Wl,-z,relro  -g -margs -j5 -R -p -XHARDWARE_PLATFORM=i386'
make -f Makefile.build SMP_MFLAGS="-j0"
make[1]: Entering directory `/builddir/build/BUILD/matreshka-0.6.0'
/usr/bin/gprbuild -cargs -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -gnatn -gnat-p -gnatVd -gnatwn -gnatyN -largs -Wl,-z,relro  -g -margs -j5 -R -p -XHARDWARE_PLATFORM=i386 -Pgnat/matreshka_league.gpr
/usr/bin/gprbuild: symbol lookup error: /usr/bin/gprbuild: undefined symbol: sax__locators___elabs
make[1]: *** [league] Error 127
make[1]: Leaving directory `/builddir/build/BUILD/matreshka-0.6.0'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.Kp65VH (%build)
RPM build errors:

Comment 1 Pavel Zhukov 2014-10-11 22:19:27 UTC
*** Bug 1106159 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.