Bug 109512 - Installer aborts when installing kdebase
Installer aborts when installing kdebase
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-08 16:30 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:29:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-11-08 16:30:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
During upgrade from RedHat 9, the installer reproducably aborted when
trying to install kdebase. It was installing kdebase because kdelib
was installed.

The error appeared to be that the kdebase RPM was trying to write a
file to a read-only filesystem during the install.

Removing kdelib and thus avoiding the installation of kdebase worked
around the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get RedHat 9 machine with kdelib installed (but not kdebase).
2. Upgrade to Fedora Core 1
3. Watch failure.
    

Actual Results:  The installer aborted and required the machine to be
rebooted. I poked around on the other consoles to see what had gone wrong.

Expected Results:  Installation

Additional info:
Comment 1 Ngo Than 2003-11-10 18:48:11 EST
i assume you have used anaconda to upgrade your system.
Comment 2 Need Real Name 2003-11-10 19:31:53 EST
Yes, I used anaconda.

The media checked fine (this happened both from a CD and from ISO
images on the HDD).

A colleague who did the upgrade didn't have this problem, but they
already had kdebase installed before the upgrade - I didn't, it was
dragged in as a dependency.
Comment 3 Jeremy Katz 2003-11-11 11:03:10 EST
Does it work if you boot with 'linux allowcddma'?
Comment 4 Need Real Name 2003-11-11 17:25:20 EST
I don't know, and the machine's upgraded now.

It's hard too see why, since it wasn't using the CDROM at the time of
the error - it was reading the RPMs from the HDD.
Comment 5 stef 2003-11-11 20:47:55 EST
we had the same problem
and fixed it by removing kdelib

now when installing kdebase we get

There was a fatal RPM install error. The message was:
There was a rpm unpack error installing the package: kdebase-3.1.4-6
Comment 6 Need Real Name 2003-11-18 23:06:41 EST
It doesn't happen if kdebase is already installed - I just upgraded my
father-in-law's machine and he had no problems.
Comment 7 Jeremy Katz 2004-10-05 11:29:30 EDT
This should be better in newer releases.

Note You need to log in before you can comment on or make changes to this bug.