Bug 109524 - no keyboard and no mouse with rhgb
no keyboard and no mouse with rhgb
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-08 20:03 EST by Mael
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-11 17:35:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mael 2003-11-08 20:03:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007

Description of problem:
Booting with rhgb the computer hangs a moment when switching to
graphical view (during this time keyboard leds flash), and then the
init continue as expected but I have no more keyboard or mouse ..
Without rhgb everything works fine
 
My configuration :
Athlon XP 1.53Gz/256MB/NVidia GeForce4 MX420
Keyboard and mouse PS/2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot with rhgb on
2.
3.
    

Additional info:
Comment 1 Vlatko Primorac 2003-11-18 10:38:38 EST
After installing the Fedora 1, I got the exact same behavior examined 
here. I repeated the installation process only to come up with the 
same result. My mouse is wheel PS/2 mouse, keyboard is the one that 
comes with e-machines, processor is AMD Athlon.

During installation, I choose the "Install Everything" option, and 
opted for "Select All" in languages support section. Installation 
seems to be working fine, except for the lack of keyboard and mouse 
after the reboot.

After few hours in First Boot section, where system waits for me to 
add new users, configure printers, sound cards and such, perhaps the 
program gives up on waiting for input and continues the normal boot. 
Much to my surprise, it actually proceeds to the login screen, and 
the keyboard and the mouse are recognized again. I could move the 
mouse around the screen and type root into login box. After finding 
this out, I opted for reboot computer from the login screen menu, and 
got into the same problem of not being able to move the mouse during 
graphical boot, and no mouse or keyboard recognized during first boot.

Using the very same installation, this bug did not occur in the last 
beta release.
Comment 2 Keith 2003-12-13 18:58:17 EST
I have the same issue. If rhgb is enabled, no keyboard or mouse. 
However, this doesn't seem to be consistent. I have forgotten to 
remove the rhgb from the boot command and the system will sometimes 
boot okay.

As a side note, while running Fedora I will occasionally lose the 
mouse or keyboard or both. I have to hard reset to recover from this.

My machine is a homebuilt based on an Epox 8K7A (non-RAID) 
motherboard, AMD Athlon CPU. My mouse is a logitech MouseMan Wheel 
and my keyboard is a logitech I-touch. I have had the same problems 
when using the mouse as both USB and PS/2, by the way.
Comment 3 Andrew Scott 2004-06-30 21:04:37 EDT
I have the same problem on a dual-celeron smp box.  However, the
keyboard and mouse never return, even when booting without rhgb. 
Essentially, as soon as grub passes off to the kernel, the keyboard
and mouse are dead.  Unplugging them and plugging them back in always
works for the keyboard, sometimes works for the mouse.
Comment 4 Daniel Veillard 2004-09-11 17:35:33 EDT
Never reproduced such problem. Comment #3 seems to be an hardware
related support issue and not related to rhgb. For the previous
comment they are relatively old, and the new udev support is likely
to change a lot of those issues.
Closing this relatively ancient bug as not reproductible so far.

  thanks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.