Bug 109528 - (i810_audio) no audio I875
(i810_audio) no audio I875
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Depends On:
Blocks: 123574
  Show dependency treegraph
Reported: 2003-11-08 20:44 EST by Paul D. Mitcheson
Modified: 2007-11-30 17:06 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-20 15:54:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
i810-dell-update.patch (50.20 KB, patch)
2004-07-02 14:12 EDT, John W. Linville
no flags Details | Diff
ac97_plugin.patch (64.83 KB, patch)
2004-09-28 12:57 EDT, John W. Linville
no flags Details | Diff
sysreport of i865 system (218.12 KB, application/x-bzip2)
2005-01-19 08:22 EST, Richard Cunningham
no flags Details

  None (edit)
Description Paul D. Mitcheson 2003-11-08 20:44:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1)
Gecko/20020920 Netscape/7.0

Description of problem:
No sound (as in release notes) for I875 audio on Dell Dimension 8300.

Unfortunately this is the standard workstation at my place of work,
and RHEW3 is the standard linux so we have no sound.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.install RHEW3
3.no sound

Additional info:

I guess you already know what is causing the problem as it is in the
release notes, but if I can help with debuggin or test kernels please
let me know.
Comment 1 Paul D. Mitcheson 2004-01-06 18:44:10 EST
Just to keep you informed, I installed 2.4.21-6.ELsmp from the beta
updates and sound still doesn't work.

Please could you give me an ETA to a fix so I can make up my mind as
to whether I should just buy a new soundcard.

Comment 2 Meta IT Team - Mentor Graphics 2004-03-04 06:43:32 EST
Hi all
I have the same issue on all Dell precision workstation ( Model 360
and 450). But the sound card is detected.
I installed RHEL 3.0 ws on two Linux Box.
- The default kernel on The Precision 360 is 2.4.21-4.EL
- the default kernel on the Precision 460 is 2.4.21-4.ELsmp
The sound card is detected when I load redhat-config-soundcard. But
there is no sound

[root@norah etc]# lspci -n -v
00:00.0 Class 0600: 8086:2578 (rev 02)
        Subsystem: 1028:0156
        Flags: bus master, fast devsel, latency 0
        Memory at e8000000 (32-bit, prefetchable) [size=128M]
        Capabilities: [e4] #09 [2106]
        Capabilities: [a0] AGP version 3.0
00:01.0 Class 0604: 8086:2579 (rev 02)
        Flags: bus master, 66Mhz, fast devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        Memory behind bridge: fd000000-feafffff
        Prefetchable memory behind bridge: f0000000-f80fffff
00:1d.0 Class 0c03: 8086:24d2 (rev 02)
        Subsystem: 1028:0156
        Flags: bus master, medium devsel, latency 0, IRQ 11
        I/O ports at ff80 [size=32]
00:1d.1 Class 0c03: 8086:24d4 (rev 02)
        Subsystem: 1028:0156
        Flags: bus master, medium devsel, latency 0, IRQ 10
        I/O ports at ff60 [size=32]
00:1d.2 Class 0c03: 8086:24d7 (rev 02)
        Subsystem: 1028:0156
        Flags: bus master, medium devsel, latency 0, IRQ 9
        I/O ports at ff40 [size=32]
00:1d.3 Class 0c03: 8086:24de (rev 02)
        Subsystem: 1028:0156
        Flags: bus master, medium devsel, latency 0, IRQ 11
        I/O ports at ff20 [size=32]
00:1d.7 Class 0c03: 8086:24dd (rev 02) (prog-if 20)
        Subsystem: 1028:0156
        Flags: bus master, medium devsel, latency 0, IRQ 5
        Memory at ffa80800 (32-bit, non-prefetchable) [size=1K]
        Capabilities: [50] Power Management version 2
        Capabilities: [58] #0a [20a0]
00:1e.0 Class 0604: 8086:244e (rev c2)
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
        I/O behind bridge: 0000d000-0000dfff
        Memory behind bridge: fcf00000-fcffffff
00:1f.0 Class 0601: 8086:24d0 (rev 02)
        Flags: bus master, medium devsel, latency 0
00:1f.1 Class 0101: 8086:24db (rev 02) (prog-if 8a [Master SecP PriP])
        Subsystem: 1028:0156
        Flags: bus master, medium devsel, latency 0, IRQ 9
        I/O ports at <ignored>
        I/O ports at <ignored>
        I/O ports at <ignored>
        I/O ports at <ignored>
        I/O ports at ffa0 [size=16]
        Memory at febffc00 (32-bit, non-prefetchable) [size=1K]
00:1f.2 Class 0101: 8086:24d1 (rev 02) (prog-if 8f [Master SecP SecO
PriP PriO])
        Subsystem: 1028:0156
        Flags: bus master, 66Mhz, medium devsel, latency 0, IRQ 9
        I/O ports at fe00 [size=8]
        I/O ports at fe10 [size=4]
        I/O ports at fe20 [size=8]
        I/O ports at fe30 [size=4]
        I/O ports at fea0 [size=16]
00:1f.3 Class 0c05: 8086:24d3 (rev 02)
        Subsystem: 1028:0156
        Flags: medium devsel, IRQ 10
        I/O ports at eda0 [size=32]
00:1f.5 Class 0401: 8086:24d5 (rev 02)
        Subsystem: 1028:0156
        Flags: bus master, medium devsel, latency 0, IRQ 10
        I/O ports at ee00 [size=256]
        I/O ports at edc0 [size=64]
        Memory at febffa00 (32-bit, non-prefetchable) [size=512]
        Memory at febff900 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
01:00.0 Class 0300: 10de:0258 (rev a3)
        Subsystem: 10de:0138
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
        Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Memory at f8000000 (32-bit, prefetchable) [size=512K]
        Expansion ROM at fea00000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 2.0
02:0c.0 Class 0200: 8086:100e (rev 02)
        Subsystem: 1028:0156
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 9
        Memory at fcfe0000 (32-bit, non-prefetchable) [size=128K]
        I/O ports at df40 [size=64]
        Capabilities: [dc] Power Management version 2
        Capabilities: [e4] PCI-X non-bridge device.
        Capabilities: [f0] Message Signalled Interrupts: 64bit+
Queue=0/0 Enable-
[root@norah etc]#

[root@norah etc]# lsmod
Module                  Size  Used by    Not tainted
i810_audio             27592   2
ac97_codec             15944   0  [i810_audio]
soundcore               6436   2  [i810_audio]
nfs                    92912   4  (autoclean)
lockd                  59856   1  (autoclean) [nfs]
sunrpc                 85692   1  (autoclean) [nfs lockd]
parport_pc             19076   1  (autoclean)
lp                      9028   0  (autoclean)
parport                37088   1  (autoclean) [parport_pc lp]
autofs                 13364   4  (autoclean)
e1000                  71712   1
sg                     36940   0  (autoclean)
sr_mod                 18104   0  (autoclean)
floppy                 58160   0  (autoclean)
microcode               4724   0  (autoclean)
ide-scsi               12208   0
ide-cd                 35680   0
cdrom                  33696   0  [sr_mod ide-cd]
keybdev                 2976   0  (unused)
mousedev                5524   1
hid                    22212   0  (unused)
input                   5888   0  [keybdev mousedev hid]
ehci-hcd               20104   0  (unused)
usb-uhci               26412   0  (unused)
usbcore                79392   1  [hid ehci-hcd usb-uhci]
ext3                   91592   3
jbd                    52336   3  [ext3]
ata_piix                3908   4
libata                 27716   0  [ata_piix]
sd_mod                 13744   8
scsi_mod              108840   5  [sg sr_mod ide-scsi ata_piix libata
[root@norah etc]#

Comment 3 Paul D. Mitcheson 2004-03-04 15:07:29 EST
one thing I didn;t make clear;  redhat-config-soundcard also finds the
soundcard in my machine too.  It just doesn;t make any noise!

Comment 4 David Lawrence 2004-03-04 15:36:42 EST
Paul, what browser are you using when making changes to this bug
report? I am trying to track down a problem with qa contact fields
getting cleared out accidently. Please comment on whether your qa
contact field is blank or not when making changes to this report. Thanks!
Comment 5 Paul D. Mitcheson 2004-03-04 15:44:15 EST
Hi David,

Mozilla 1.6 on windoze box at the moment.

QA contact is listed fine.


Comment 6 Jason Smith 2004-04-01 10:45:07 EST
Why has no one from RedHat responded to this ticket yet, except to ask
which browser someone was using?  As far as I know RHEL-3 is supported
by RedHat, correct?  I have a Dell Precicion 360 with the same sound
card which was shipped from Dell with RedHat-9 installed and the sound
card worked perfectly.  Because of 9's EOL state we are upgrading to
RHEL here and now my sound card doesn't work.  Can someone from RedHat
please respond to this ticket....

Relevant information:

$ lspci -vvx

00:1f.5 Multimedia audio controller: Intel Corp. 82801EB AC'97 Audio
Controller (rev 02)
        Subsystem: Dell Computer Corporation: Unknown device 0156
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 17
        Region 0: I/O ports at ee00 [size=256]
        Region 1: I/O ports at edc0 [size=64]
        Region 2: Memory at febffa00 (32-bit, non-prefetchable) [size=512]
        Region 3: Memory at febff900 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
00: 86 80 d5 24 07 00 90 02 02 00 01 04 00 00 00 00
10: 01 ee 00 00 c1 ed 00 00 00 fa bf fe 00 f9 bf fe
20: 00 00 00 00 00 00 00 00 00 00 00 00 28 10 56 01
30: 00 00 00 00 50 00 00 00 00 00 00 00 0a 02 00 00
Comment 7 Paul D. Mitcheson 2004-04-01 10:51:53 EST
To follow up Jason's comment, I am also starting to get a annoyed by
the lack of input from redhat on this issue.

These EL3 licenses are not cheap!

Comment 10 Jason Smith 2004-04-07 10:13:10 EDT
If someone from RedHat would care to comment on this bug then perhaps
we can help you fix this.  If you don't have access to this hardware
then maybe myself or Paul can help you to debug or test a new driver.
 But, before this can ever happen, someone from RedHat will have to at
least respond to this bug report.  If the owner of this bug does not
have the time or does not feel like doing anything, can you at least
reassign it to someone who will respond?
Comment 11 Tim Burke 2004-04-07 10:43:04 EDT
We will be looking into the matter, but have been consumed with other
issues to date.  The Dell Dimension isn't a certified RHEL system, as
shown on hardware.redhat.com.  We do try to go out of our way to look
at issues beyond whats hardware certified, but sometimes that takes us
Comment 12 Pete Zaitcev 2004-04-07 11:28:27 EDT
Actually, I found a WS420 which has an onboard Intel audio,
installed RHEL 3 beta on it. Just need to poke some more.
Strangely, it shipped with an add-on sound (emu10k) from
the factory, maybe Dell never counted on onboard sound working.

But I suspect it will need help from the bug requestor in the end.
Seems like i810 has a history of revision-specific problems.
Comment 13 Paul D. Mitcheson 2004-04-07 12:22:36 EDT
Hi Tim,

Thanks for the response.

I look forward to a resolution,

Comment 14 David E. Cox 2004-04-14 14:54:58 EDT
I have a dell dimension 4600 with similar lspci info.  It auto-detects
sound as i810_audio, but generates no actual sound output.  However,
it turns out the black "surround?" output does produce audio, even
though there is no signal on the typical green stereo audio output.
Comment 15 Paul D. Mitcheson 2004-05-13 15:27:26 EDT
Hi Tim,

Now that update 2 is out of the way would there be any chance you can
look at this i810 issue soonish?

Comment 16 Barry K. Nathan 2004-06-26 01:30:53 EDT
FWIW, Dell has a modified i810_audio driver for RHEL 3. To download it
(disclaimer: these instructions are off the top of my head):

-Go to http://support.dell.com/
-Pretend you're a home user (even if you're not)
-Click "Select Another System" (unless it asks you up front to choose
a type of machine)
-Choose "Precision Workstation 360n"
-Go to "Downloads"
-Search for an Audio driver for Red Hat Enterprise Linux 3 with
English language
-Click on the link for whatever model of Analog Devices chip (there's
only one link on the page that fits this description)
-I think things should be obvious from there...

BTW, this problem is mentioned in the dead-tree documentation that
came with a Dell Precision Workstation 360n that my organization
purchased. According to that documentation, Red Hat will be fixing
this bug in a future erratum package. ;) Also, this Precision came
with ALSA preloaded by Dell, but Dell's ALSA package doesn't work with
2.4.21-15.EL or later, which is how I found this modified i810_audio
Comment 17 Paul D. Mitcheson 2004-06-26 20:33:51 EDT
Hi everyone,

Barry: - fantastic!  That works a treat.

Redhat: - does this mean you can integrate the dell driver into EL3

Cheers, guys,

Comment 18 Pete Zaitcev 2004-06-26 21:57:59 EDT
John Linnville did a backport already, actually. It's in my
review pile. I was going to run a diff between his version and
the Dell version. But since this bug keeps falling off the far
edge of my plate, I think I'll try to toss it over to him.
Comment 19 John W. Linville 2004-07-01 13:53:53 EDT
I've got a Precision 450 here that refuses to make sound, even with
the driver Barry found from Dell's site.

This may take a while, but at least I have a vested interest... :-)
Comment 20 Paul D. Mitcheson 2004-07-01 18:52:38 EDT
Come on, John - wouldn't it be nice to go into the weekend knowing
that you had sound on your Dell Precision? :-)

Please let me know if and when you want me to test a kernel.


Comment 21 John W. Linville 2004-07-02 14:12:26 EDT
Created attachment 101605 [details]

Attached is a patch incorporating the Dell patch along with some other updates.
 I'd love to hear the results of applying it to the kernel-2.4.21-9.EL

Sound on my box is now working, albeit for other reasons.  Now I can enjoy my
weekend... :-)
Comment 23 Ernie Petrides 2004-09-01 22:44:18 EDT
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-20.2.EL).
Comment 24 Paul D. Mitcheson 2004-09-03 19:49:06 EDT
Hi Ernie - that's great.

Is it possible for me to get an rpm of this?


Comment 25 Ernie Petrides 2004-09-07 16:56:38 EDT
Hi, Paul.  It will be a few months before U4 is released.  Our
regular internal-to-Red-Hat-Engineering builds have not yet gone
through any Q/A, and 2.4.21-20.2.EL is only the 2nd build of the
U4 cycle (with probably a couple of dozen left to go).

All that being said, if you want to test an RPM in advance, and
you understand that this would not be a supported kernel and would
not be suitable for production use, I could make one available to
you.  If this is what you're interested in, please let me know the
exact RPM name or associated arch/config.  (For example, the RPM
name of the x86 SMP kernel is kernel-smp-2.4.21-20.2.EL.i686.rpm.)
Comment 26 Paul D. Mitcheson 2004-09-07 17:17:36 EDT
Hi Ernie,

Yes please - I'd like to give it a test!

So, i686 smp please.


Many thanks for this!

Comment 27 Ernie Petrides 2004-09-07 18:40:11 EDT
Okay, use the following link to download the RPM:


Let me know how it goes.  -ernie
Comment 28 Paul D. Mitcheson 2004-09-07 18:45:30 EDT
Ernie - great.  Installed.  But I need the source rpm too to recompile
my nvidia graphcs driver against.  Could you put that up for me too?

Comment 29 Ernie Petrides 2004-09-07 19:01:16 EDT
Okay, here it is:


I had to remove the prior RPM due to space restrictions.
Comment 30 Paul D. Mitcheson 2004-09-07 19:39:40 EDT
Hi Ernie,

Sorry - your new kernel boots and seems to work fine - but no change
in sound.  

Same problem as before;  the surround port produces sound but the
green output produces nothing.

hhhmmmm any output I can send you?

Comment 31 John W. Linville 2004-09-08 08:23:15 EDT
Paul, et al.

I apologize for not posting the require changes to /etc/modules.conf!

Anyway, you need to add a line like this in /etc/modules.conf:

pre-install sound-slot-0 /sbin/modprobe ac97_plugin_ad1980

I apologize for the confusion!


P.S. Unfortunately, I don't know of any way to make this happen
"automatically".  Manually adding that line in /etc/modules.conf is
the only option.
Comment 32 Ernie Petrides 2004-09-08 15:28:36 EDT
Thanks, John.

Paul, I should mention that in the -20.2.EL kernel, we hadn't
yet added the following lines to config-x86-generic:


This addition was committed to the -20.3.EL kernel, so you might
need that to provide the plugin module that John refers to (unless
you want to build it yourself from the source).  Let me know if you
need the -20.3.EL kernel RPMs to facilitate your testing.
Comment 33 Paul D. Mitcheson 2004-09-08 19:19:10 EDT
Hi Ernie,

Please - if you can give me the -20.3.EL RPM (smp for 686 and source)
to save me compiling.

I was about to write and say it's not working!


Comment 34 Ernie Petrides 2004-09-08 21:55:54 EDT
I managed to get space for both RPMs this time.  Please use the
following links for your download:


You might still need the /etc/modules.conf line that John posted
in comment 31.

Sorry about having to iterate on this.  Let me know how things go.

Cheers.  -ernie
Comment 35 Paul D. Mitcheson 2004-09-09 04:42:34 EDT
That's got it guys!

Thanks a lot.

Comment 36 Jason Smith 2004-09-27 17:48:27 EDT
Could you please attach an updated patch for this bug which will work
against the 2.4.21-20.EL kernel from your Q3 update, with the kernel
driver config part from comment 32 included also?  I tried using the
patch posted a few months ago, but several hunks failed to apply.  The
patched kernels from a few weeks ago are already gone from ~petrides

Comment 37 John W. Linville 2004-09-28 12:57:34 EDT
Created attachment 104446 [details]

By your command! :-)
Comment 38 Ernie Petrides 2004-10-20 16:12:12 EDT
*** Bug 134380 has been marked as a duplicate of this bug. ***
Comment 42 John Flanagan 2004-12-20 15:54:48 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

Comment 43 Richard Cunningham 2005-01-17 11:44:22 EST
I can't get this to work with redhat-config-soundcard or xmms on the
Intel D865GLC motherboards we have.

Some (hopefully) relevant information:

$ redhat-config-soundcard
i810_audio: Device or resource busy

# lsmod
Module                  Size  Used by    Tainted: P
i810_audio             28824   1  (autoclean)
ac97_plugin_ad1980      1100   0  (unused)
ac97_codec             16840   0  (autoclean) [i810_audio
soundcore               6436   2  (autoclean) [i810_audio]
agpgart                57752   3  (autoclean)
nvidia               3408184   6  (autoclean)
nfs                    95348   3  (autoclean)
lockd                  58832   1  (autoclean) [nfs]
sunrpc                 82140   1  (autoclean) [nfs lockd]
autofs4                15928   5  (autoclean)
audit                  89816   3
e100                   57008   1
ipt_REJECT              4600   1  (autoclean)
iptable_filter          2412   1  (autoclean)
ip_tables              15776   2  [ipt_REJECT iptable_filter]
microcode               5688   0  (autoclean)
ide-scsi               12336   0
scsi_mod              106408   1  [ide-scsi]
ide-cd                 33920   0
cdrom                  32416   0  [ide-cd]
ext3                   85768   4  (autoclean)
jbd                    50652   4  (autoclean) [ext3]
keybdev                 2944   0  (unused)
mousedev                5524   0  (unused)
hid                    22116   0  (unused)
input                   5888   0  [keybdev mousedev hid]
ehci-hcd               20008   0  (unused)
usb-uhci               25740   0  (unused)
usbcore                77376   1  [hid ehci-hcd usb-uhci]

# dmesg |grep -i audio
Intel 810 + AC97 Audio, version 1.01, 19:02:54 Dec 20 2004
i810_audio: Primary codec has ID 2
i810_audio: Audio Controller supports 6 channels.
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
i810_audio: Connection 0 with codec id 2
ac97_codec: AC97 Audio codec, id: ADS117 (Unknown)
i810_audio: AC'97 codec 2 supports AMAP, total channels = 6
Comment 44 Richard Cunningham 2005-01-17 11:46:12 EST
I forgot to mention I using the 2.4.21-27.0.1EL kernel
Comment 45 John W. Linville 2005-01-17 12:29:22 EST
i810_audio: Device or resource busy

This would seem to indicate that something is using the device.  Have
you tried running redhat-config-soundcard while X is NOT running?
Comment 46 Richard Cunningham 2005-01-17 13:17:28 EST
If I try to do this I get...
redhat-config-soundcard requires a currently running X server.
Try running 'sndconfig' instead.

and I don't seem to have sndconfig (i've got almost all the RPMs

if I use the "play" command to play a wav file I get no errors and no

I get the same "i810_audio: Device or resource busy" error with
redhat-config-soundcard on our i845 systems - but the test sound does

redhat-config-soundcard and xmms sometimes fail like this:

$ redhat-config-soundcard
i810_audio: Device or resource busy
sox: Can't open output file '/dev/dsp': Device or resource busy
$ lsof |grep dsp
artsd     2777  rjc    9w   CHR       14,3              32961 /dev/dsp
$ ps -ef |grep [2]777
rjc       2777  2756  0 17:56 ?        00:00:00 /usr/bin/artsd -F 10
-S 4096 -s 60 -m artsmessage -l 3 -f

...so I wait until "lsof |grep dsp" shows nothing and try again (this
also happens on the otherwise working i845 systems)
Comment 47 John W. Linville 2005-01-18 15:14:30 EST
Richard, please attach the output of running sysreport on the failing box.
Comment 48 Richard Cunningham 2005-01-19 08:22:45 EST
Created attachment 109965 [details]
sysreport of i865 system

Here is the sysreport, I did it on a fresh install on one of these machines
just to make sure it wasn't any of our local configurations causing the

Note You need to log in before you can comment on or make changes to this bug.