Bug 109553 - Changing GNOME theme crashes RHN applet
Changing GNOME theme crashes RHN applet
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 11:08 EST by J. J. Ramsey
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-13 14:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. J. Ramsey 2003-11-09 11:08:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
When I change the theme from Bluecurve to Crux, rhn-applet crashes. If
I restore the RHN system tray icon, another theme change usually won't
crash it.


Version-Release number of selected component (if applicable):
rhn-applet-2.1.2-1

How reproducible:
Sometimes
Comment 1 Daniel Veillard 2003-11-09 14:59:31 EST
Hum, right ... I didn't reproduce it on that theme transition
but after launching the Themes Preference selectors and switching
a dozen times I got the applet crash too:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1084365504 (LWP 31293)]
0x010305ef in gtk_container_set_border_width ()
   from /usr/lib/libgtk-x11-2.0.so.0
(gdb) where
#0  0x010305ef in gtk_container_set_border_width ()
   from /usr/lib/libgtk-x11-2.0.so.0
#1  0x0104307c in gtk_dialog_get_type () from /usr/lib/libgtk-x11-2.0.so.0
#2  0x00d55d4e in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib/libgobject-2.0.so.0
#3  0x00d43007 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#4  0x00d42cb0 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#5  0x00d5449d in g_signal_emit_by_name () from
/usr/lib/libgobject-2.0.so.0
#6  0x00d53c36 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
(gdb)

  I don't understand why the stack trace stops at level #6,
but the bug seems to happen in gtk. It may be related to the 
python bindings but I can't really find where it crashes there
without the full stack trace. 

Daniel
Comment 2 Matthias Clasen 2004-05-13 13:34:11 EDT
I can't reproduce this with gtk2-2.4.0-1 and rhn-applet-2.1.7-1.1.
What I do notice though is that the rhn-applet is the slowest part of
the desktop to pick up the new theme...

Note You need to log in before you can comment on or make changes to this bug.