Bug 109555 - Metacity/Bluecurve doesn't obey "Fitt's Law" when maximized
Metacity/Bluecurve doesn't obey "Fitt's Law" when maximized
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 11:16 EST by Hamilton Leeper
Modified: 2014-01-21 17:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 15:35:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hamilton Leeper 2003-11-09 11:16:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030 Epiphany/1.0.4

Description of problem:
I don't know if this is intended behavior or not, but maximized
windows in GNOME using metacity don't obey Fitt's law; for example,
when the mouse is pressed against the top right of the screen and
clicked, it grabs the menubar instead of activating the close button.
 I think it should behave according to Fitt's law since the rest of
GNOME strives to  behave this way too.

Thanks

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Maximize a window
2. Notice how moving the mouse against the top left or right edge of
the screen and clicking doesn't activate a button.
3.
    

Additional info:
Comment 1 Seth Vidal 2003-11-12 16:28:04 EST
triage->upstream

also - an explanation of fitt's law would be useful when you file it
upstream.
Comment 2 Hamilton Leeper 2003-11-12 18:18:54 EST
From the GNOME 2.4 release notes:

"The panel and all applets now comply with "Fitt's Law" — You can
click on them at the very edge of the screen"

Sorry if that wasn't clear 8)

By the way, what exactly does it mean to file a bug "upstream"?  I'm
kind of new to bugzilla.
Comment 3 Seth Vidal 2003-11-12 18:20:30 EST
bugzilla.gnome.org - this bug isn't a red hat bug it's most likely a
metacity bug and therefore should be filed upstream, at gnome's bugzilla.
Comment 4 Jef Spaleta 2004-01-29 13:47:31 EST
Please report back to this bug, when you do file it upstream.
It's good to have the upstream bugnumber references here.
Comment 5 Craig Routledge 2004-02-22 15:57:48 EST
This was filed upstream to Gnome at

http://bugzilla.gnome.org/show_bug.cgi?id=97703

Note that there is some debate there as to whether this should be
fixed in the shipped themes or in metacity itself.

Note You need to log in before you can comment on or make changes to this bug.