Bug 10957 - X stalls when can't determine hostname
Summary: X stalls when can't determine hostname
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-21 05:19 UTC by caseg
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 16:28:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description caseg 2000-04-21 05:19:37 UTC
My roommate and I share a cable modem, since I haven't gotten around to
configuring a firewall/gateway box for our local network.  We just unplug
one machine from the back of the cable modem and plug in the other.  I've
noticed that when I'm unplugged, as if I were still online, when I type
'startx', it stalls for about 2 minutes, then finally kicks in and starts X
like normal.  When I look at the output of 'startx', I notice that there is
a line something like:  'xauth: cannot determine hostname'.  My hostname is
the one given me by my cable modem provider.

Comment 1 Mike A. Harris 2001-05-20 22:25:05 UTC
This is a DNS misconfiguration problem, not an X bug.  Please configure
your /etc/hosts and /etc/resolv.conf properly to avoid this problem with
X, and with other network services as well.


Note You need to log in before you can comment on or make changes to this bug.