Bug 109580 - Problem with dhcp and network aliases in redhat-config-network
Summary: Problem with dhcp and network aliases in redhat-config-network
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-09 20:39 UTC by Peter Fales
Modified: 2014-03-17 02:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 03:00:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Fales 2003-11-09 20:39:12 UTC
Description of problem:

I have several profiles created with redhat-config-network.  If
the interfaces use dhcp and a non-default nickname, I get errors from
/sbin/dhclient

It looks like what happens is that the scripts in
/etc/sysconfig/network-scripts get created based on the nickname of
the interface, eg. ifcfg-eth0_dhcp.   When the interface is activated,
the name eth0 is passed to /sbin/dhclient-script, which generates
errors, because it is expecting to find a file named
/etc/sysconfig/network-scripts/ifcfg-eth0, rather than the file
which is actually there: /etc/sysconfig/network-scripts/ifcfg-eth0_dhcp

Version-Release number of selected component (if applicable):


How reproducible:

Very

Steps to Reproduce:
1.  Create a new profile
2.  Create an interface in the that profile with a nickname, e.g
    eth0_dhcp. It should get the IP address using dhcp
3.  Activate that interface
  
Actual results:

Error from /sbin/dchclient-script:
configuration for eth0 not found

Expected results:

eth0 should be activated without errors


Additional info:

If the nickname is changed back to eth0, things work properly

Comment 1 Sergey V. Udaltsov 2003-11-13 10:28:48 UTC
I tried to overcome this problem by creating several nicknames to the
same device (eth0_dhcp as eth0, eth0_home as eth0:1 - using alias 1)
and make them active in different profiles - but unfortunately aliases
(eth0:1 etc) are not activated during the boot process. Should I fill
special bug about this - or can we discuss this here as well?

Comment 2 jason 2003-11-17 17:02:30 UTC
Experiencing the same problems. This makes profiles useless which in
turn makes networking on laptops a pain.  I'd love to try to offer a
fix, but I'm not sure what the intended behavior is, whether it should
be ifup <nickname> or ifup <deviceid>.  




Comment 3 Peter Fales 2003-11-17 17:22:10 UTC
Under RH9, the script that is created in
/etc/sysconfig/network-scripts is "ifcfg-eth0" and is activated by
saying "ifup eth0" even if eth0 has a different nickname.


Comment 4 jason 2003-11-17 17:50:55 UTC
yes, i know that to be true, but looking at the current state it's
unclear whether the current behavior is a bug or a half completed move
to a new scheme. =(

Comment 5 Harald Hoyer 2003-11-25 15:16:18 UTC
this is a new naming scheme and should be fixed in dhclient or the
initscript that calls dhclient should provide the config file name.

reassigning to initscripts

Comment 6 Bill Nottingham 2004-01-28 17:42:35 UTC
Please attach the config files in use.

Comment 7 Peter Fales 2004-01-28 17:56:11 UTC
I'm not sure what you mean by the config file?  Do you mean
/etc/sysconfig/network-scripts/ifcfg-eth0_dhcp

Comment 8 Bill Nottingham 2004-01-28 17:58:53 UTC
Whatever ifcfg file is causing the error, and your /etc/modules.conf.

Comment 9 jason 2004-01-28 18:15:28 UTC
from what i remember, it's not a problem with the scripts.  It's the
fact that initscript is calling 'ifup eth1' but redhat-config-network
names the scripts 'ifcfg-eth1-<alias>' so the script ifcfg-eth1
doesn't exist and dhclient-script or whatever it is bombs out with a
file not found error

Comment 10 Peter Fales 2004-01-28 18:22:38 UTC
Hey, I can't reproduce the problem now!  I do pull updates for this
system, and I see that there has been an update to initiscripts since
I wrote this bug report.  Maybe it got fixed.

Comment 11 Bill Nottingham 2004-03-17 03:00:57 UTC
There were some fixes in initscripts in the update - please reopen if
it persists.


Note You need to log in before you can comment on or make changes to this bug.