Bug 109582 - zone file gives "not at top of zone error"
zone file gives "not at top of zone error"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-config-bind (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 15:42 EST by Fergal Daly
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: s-c-b-4.0.0-16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-03 12:44:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fergal Daly 2003-11-09 15:42:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
the zone files from a simple setup don't work and give the error

Nov  9 20:27:13 whizzo named: named reload succeeded
Nov  9 15:27:34 whizzo named[4347]: loading configuration from
'/etc/named.conf'
Nov  9 15:27:34 whizzo named[4347]: no IPv6 interfaces found
Nov  9 15:27:34 whizzo named[4347]: dns_master_load: loc.zone:14:
whizzo.loc: not at top of zone
Nov  9 15:27:34 whizzo named[4347]: zone loc/IN: loading master file
loc.zone: not at top of zone
Nov  9 20:27:34 whizzo named: named reload succeeded

Also, I had to add
options {
        directory "/var/named";
};

to /var/names/chroot/etc/named.conf to get past the file not found
errors, presumably due to the chroot stuff.
(sorry for not doing that as a separate bug but mozilla is also giving
me grief)


Version-Release number of selected component (if applicable):
redhat-config-bind-2.0.0-18

How reproducible:
Always

Steps to Reproduce:
1.Clink New, fill in loc as the zone name, click ok, fill in
whizzo.loc. as the SOA

2. Now click add record, add a host record with ost name whizzo.loc
and 10.0.0.2 as address, click OK

3. Clicking Save now tells you that you must add a nameserver record
so click add record, nameserver. Not entriely sure what to put in here
so I put whizzo in the first field and whizzo.loc in the second. I
also tried leaving the first blank.
    
4. Save everything and quit




Actual Results:  loc.zone file looks like

$TTL 86400
whizzo.loc.     IN      SOA     localhost       root    (
                                5 ; serial
                                28800 ; refresh
                                14400 ; retry
                                3600000 ; expire
                                86400 ; ttl
                                )



whizzo  IN      NS      whizzo

whizzo          IN      A       10.0.0.2



Expected Results:  a zone file that works, for instance

$TTL 86400
@       IN      SOA     localhost       root    (
                                18 ; serial
                                28800 ; refresh
                                14400 ; retry
                                3600000 ; expire
                                86400 ; ttl
                                )

                NS      whizzo.loc



whizzo.loc              IN      A       10.0.0.2


Additional info:
Comment 1 Daniel Walsh 2004-01-05 17:04:27 EST
Major updates to system-config-bind have been done  Please check it out.

Dan
Comment 2 Fergal Daly 2004-01-08 16:42:46 EST
It's exactly the same as far as I can see. It still produces a zone
file that is broken. No @ at the beginning of the SOA line. 

It also puts the NS after the IN line (or at least it can in some
circumstances) bind seems to be unhappy about this, requiring the NS
entry to come straight after the SOA.

By the way, double clicking or trying to get properties of an NS
record gives me a python backtrace
Comment 3 Jonathan Pool 2004-09-25 19:02:25 EDT
Same problem with redhat-config-bind-2.0.0-14.2 in RHEL 3.
Comment 4 Jason Vas Dias 2005-06-03 12:44:08 EDT
This problem is fixed with system-config-bind-4.0.0-16 (FC-3/4/RHEL-4),
also available at: http://people.redhat.com/~jvdias/system-config-bind
and with redhat-config-bind-4.0.0-16 (RHEL-3), available from 
http://people.redhat.com/~jvdias/redhat-config-bind.

Note You need to log in before you can comment on or make changes to this bug.