Bug 109591 - anaconda stops during install after finding monitor
anaconda stops during install after finding monitor
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
athlon Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 16:55 EST by Benj FitzPatrick
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:33:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benj FitzPatrick 2003-11-09 16:55:04 EST
Description of problem:  When running the installer (regular or text)
anaconda finds the video card (gf4 mx 400) and monitor and it hangs
there.  The cursor stops blinking and all hd activity stops after 10
seconds.


Version-Release number of selected component (if applicable):


How reproducible:  I have tried 4 installs, and all of them hang at
this point.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2003-11-10 16:40:10 EST
Is this with a flat panel attached via the DVI interface?
Comment 2 Benj FitzPatrick 2003-11-10 18:51:28 EST
Nope, it is a CRT (Mitsubishi Diamond Pro 2060u) attached with DSub
through a belkin KVM (omniview 4 port usb, but I don't think it is a
problem with the kvm or monitor since core 1 installed fine on another
computer (shuttle ak31 w/ radeon AIW ve) using the same kvm and monitor).
Comment 3 Jeremy Katz 2003-11-11 11:04:09 EST
Can you switch ttys at all?  Are any keyboard LEDs flashing (if not,
do they still function correctly)?  Does it work if you boot with
'linux text'?
Comment 4 Benj FitzPatrick 2003-11-11 11:27:03 EST
I can't switch ttys, and the kb LEDs aren't flashing.  It is pretty
much a hard lock.  It happens with "linux text" as well.
Comment 5 Jeremy Katz 2003-11-11 11:32:42 EST
Can you try booting with 'linux headless' and 'linux skipddc'?
Comment 6 Benj FitzPatrick 2003-11-11 17:19:53 EST
I think that linux headless will work.  It gets to anaconda and says
"Display variable not set.  Starting in text mode."  Then it goes on
to the rest of the install (I won't have time to complete the install
until about thursday night, so I don't know if it works overall).  The
linux skipddc did not work, it hung at the same spot just after
finding the monitor and before finding the mouse.  Thanks for your help.
Comment 7 Marcos Carneiro da Rocha 2003-11-15 21:27:51 EST
My machine is k6-II and when i start with 'linux headless' or 'linux
skipddc' doen't work. Some times anaconda hungs when selecting
packages to install.
Comment 8 Robert Innamorato 2004-01-06 21:22:59 EST
Hi 
My name is Rob and I am experiencing the same problem.  I have a 
relatively old NEC MultiSync XV17+ Monitor.  It usually works fine.
I formatted the C: drive, booted from A: floppy with Linux install 
disk.  The boot disk finds the CDROM and starts the install.  
Anaconda starts and my monitor blacks-out.  

My hardware is: Pentium II, 266 mhz.
192 mb RAM
3d video card with 8 mb

I can be reached at roberti813@msn.com

Thanks
Comment 9 Darin 2004-02-25 03:43:34 EST
I have an additional twist to this problem:

I'm running a Dell laptop that I'm trying to install Linux on. The
problem is that the DVD/CD drive only reads DVDs now. So ... I found a
DVD iso image with all 3 isos on there. 

So now I should be able to boot from the DVD drive, right? Wrong. For
some reason even after I have moved the DVD drive to top priority in
the boot order in the BIOS, the DVD drive won't boot my fancy new ISO. 

So ... I have finally figured a way to get into the drive from DOS
(after having suffered hunting down a driver for the CD drive and
getting that to work) and to use the \DOSUTILS\AUTOBOOT program and
that is where I run into the hanging once X loads up. I actually get
the Fedora Core screen and then it hangs. Anaconda actually mentions
at one point that the monitor is unrecognized or something similar.

So, I think that I need to run the install with the 'skipddc' option,
but I can't figure a way to get that to happen when loading from DOS
and I can't get the DVD to boot at startup to type in the option at
the beginning. 

Thanks! 

Darin

I'll check back here, but if you beat me to it, I can be reached at:
drappleshin@yahoo.com
Comment 10 Darin 2004-02-25 11:41:47 EST
Never mind! I woke up this morning and out of desperation/good night
of sleep/curiosity ran the following command that worked:

AUTOBOOT AUTORUN

Somehow the installation ran a little differently and kicked right in.
It's going as I type this! 
Comment 11 Rodney 2004-03-09 16:55:01 EST
I had the same problem stated by Benj FitzPatrick's original post.  
It was driving me nuts.  I disconnected my KVM and the install went 
without issues.  I tried all the install options that made sense, and 
it simply didnt work for me.  Then I decided to plug the monitor, 
mouse and keyboard directly into the machine and get it over with.

BTW, my install hung after my flat panel was detected, just as yours 
did, but the actual problem was the mouse and keyboard probe that 
follows....

Best wishes...

rodney@vestalsgap.com
Comment 12 enos 2004-05-30 04:31:09 EDT
Try unplugging all serial devices.

My FC2 installation used to hang after detecting the monitor, before
probing the mouse. I disconnected my Calcomp serial tablet, rebooted,
and anaconda started successfully (with me linux headless hanged at
50% of post-install configuration)

Stay well.
Comment 13 Darrin McMurry 2004-07-01 06:28:49 EDT
Hi all,

I'm having a simalar problem to the original post. Anytime graphics 
should be up on the screen my monitor will start to hum then go 
blank. Text install works fine until after the reboot. Right after 
the line "Press I for interactive boot" ( loose paraphrase ) my 
monitor starts humming to itsself again and goes blank. Just for 
grins I took an older monitor and reinstalled in graphical mode, 
every thing went beautifully. Is this a problem with multisync 
monitors and X? This also happens with different flavors of Linux. 
Mandrake also gives my monitor fits in graphics mode. Durring the 
text install I chose the DX1495 monitor from the list of choices but 
noticed that the specs for this monitor are not correct. H freq reads 
as 30-50 which is ok but the V freq reads as 50-120 but should be 50-
100. Even after changing this to the correct values my monitor still 
hums. Are there any config files or settings that I should check for 
correct values.

My equiptment is: DFI 875b Pro MB ( Intel 875b chipset )
                  2.4GHZ P4 800fsb w/HT
                  MSI Nvida Fx5200 TD128 Vidio
                  MAG Innovision DX1495 Monitor

Any advice would be appriciated.
Comment 14 Jeremy Katz 2004-10-05 11:33:49 EDT
This should be better in newer releases.

Note You need to log in before you can comment on or make changes to this bug.