Bug 109594 - Cannot run Mozilla
Cannot run Mozilla
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 17:16 EST by Wojciech Kazubski
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-02 17:07:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wojciech Kazubski 2003-11-09 17:16:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.20-20.9 i686)

Description of problem:
Cannot run Mozilla.
If launched from KDE menu, cursor blinks for some time but nothing
happens.
When typed "mozilla" in command prompt got return to shell in about 2
seconds, without any messages.
When started with "mozilla -v" the message:
 Mozilla 1.4.1, Copyright (c) 2003 mozilla.org, build 2003103016
so the mozilla is there

Version-Release number of selected component (if applicable):
mozilla-1.4.1-17

How reproducible:
Always

Steps to Reproduce:
1.run mozilla
2.
3.
    

Actual Results:  nothing

Expected Results:  mozilla window appearing

Additional info:

May be caused by setting locale to Polish.
Comment 1 Rasmus Back 2003-11-10 17:09:58 EST
I had this same problem after upgrading from redhat9. Deleting the
java plug-in (or symlink to it) from /usr/lib/mozilla/plugins fixed it
for me.
Comment 2 Den 2003-11-11 05:37:18 EST
Please see bug 108719.
Comment 3 Den 2003-11-11 06:16:53 EST
To start mozilla in your locale just comment out lines 183,184 and 185
in /usr/bin/mozilla. It's interim measure but it's must help.

Lines (mozilla 1.4.1-15): 
# check system locale
MOZARGS=
MOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*|-\1|g"`
[ -f $MOZILLA_FIVE_HOME/chrome/$MOZLOCALE.jar ] && MOZARGS="-UILocale
$MOZLOCALE"
Comment 4 Per Bjornsson 2003-11-11 12:54:43 EST
This seems to address two different issues: the locale issue and the
Java plugin issue - just like Rasmus (comment #1) Mozilla crashed on
me after upgrading from RHL9 to FC1. Turns out that the Java plugin
link pointed to the wrong version of the JRE - I had installed Sun's
J2SDK 1.4.2, but the symlink didn't point to the plugin that was
compiled with GCC 3.2 (strangely enough it was the other one that
worked for me under RHL9, that's why I had done it like this). After
changing the symlink to the Java plugin in the 'ns610-gcc32' directory
Mozilla works and Java applets seem fine as well.

The 'bug' in Mozilla simply seems to be that a plugin that dies can
take down the browser without any indication of what happened. Of
course, it would be best if a non-functional plugin just stayed dead,
but if it can at least be caught that would be useful for troubleshooting.
Comment 5 Christopher Blizzard 2003-12-02 17:07:46 EST
Unfortunately, we can't fix that in the plugin since it's not open source.

Note You need to log in before you can comment on or make changes to this bug.