Bug 109610 - Bad configuration in modules.conf for PCMCIA network cards
Bad configuration in modules.conf for PCMCIA network cards
Status: CLOSED DUPLICATE of bug 121742
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 03:49 EST by Yovko Lambrev
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yovko Lambrev 2003-11-10 03:49:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
I have 3Com Megahertz PCMCIA card (10/100LAN+56MODEM) and it has
worked perfect for many years. I used to use RedHat (5.0-9) for my
desktop 4 days ago. Now I am with Fedora Core 1 and noticed that after
installation I had this for my PCMCIA card in /etc/modules.conf:

alias eth1 serial_cs
alias eth0 3c574_cs

First line is for my modem and second for my network interface...
The problem is that network service starts before the pcmcia service,
so everytime I will recieve an error message with delaying init for my
network.

I fixed the problem (as it is fixed in RedHat 9) removing these lines
and wrote only:

alias 3c574_cs

(without eth0)

I don't need even eth1 for my modem actually...

It's a good idea to be fixed in next releases also because of many
laptop users...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Just try to start a laptop with PCMCIA network card activated on boot

    

Additional info:
Comment 1 Yovko Lambrev 2003-11-10 04:27:30 EST
More info from my /etc/sysconfig/hwconf file for this PCMCIA card:

-
class: NETWORK
bus: PCMCIA
detached: 30
device: eth0
driver: 3c574_cs
desc: "3Com/Megahertz 3CCFEM556 Ethernet/Modem"
network.hwaddr: 00:00:86:32:F6:50
vendorId: 0101
deviceId: 0556
function: 0
slot: 0
-
class: NETWORK
bus: PCMCIA
detached: 30
device: eth1
driver: serial_cs
desc: "3Com/Megahertz 3CCFEM556 Ethernet/Modem"
vendorId: 0101
deviceId: 0556
function: 1
slot: 0
-

You can see that the modem is recognized as eth1 network device with
serial_cs driver...

The card works perfect without these selected entries.
Comment 2 Bill Nottingham 2004-08-27 18:41:32 EDT

*** This bug has been marked as a duplicate of 121742 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.