Bug 109633 - Handling of uniquely-named traces.
Handling of uniquely-named traces.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: logrotate (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 09:45 EST by Nicolas Mailhot
Modified: 2015-01-07 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 13:36:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2003-11-10 09:45:39 EST
I have several apps that output uniquely-named traces/logs in a log
dir (name unicity is achieved adding PID, start date or a sequence
number to the file name).

Once the trace/logs are generated they won't change ever.

logrotate fails miserably when handled this kind of files. It rotates
them once, then stops. (or else you tell it to create a new empty file
on rotation and rotate on empty files and after some time you fill
your disks with empty files or even non-empty files if you use
compression).

There seems to be no easy way to tell logrotate to :
1. rotate unconditionnaly traces
2. remove them after a few rotations/time and forget they ever existed.

Or am I missing something ?
Comment 1 Elliot Lee 2003-12-17 14:39:43 EST
I don't think logrotate is meant to handle these type of situations.
The tmpwatch utility might be better suited - it can delete files
after they are a certain number of days old.
Comment 2 Nicolas Mailhot 2003-12-18 04:15:58 EST
tmpwatch won't do compression like logwatch...
.
Consider it a rfe then. From a technical POV this might be different, 
from an admin/user POV handling all sorts of traces/logs in the same
files is a must.
Comment 3 Nicolas Mailhot 2003-12-19 03:52:59 EST
(for example some apps use combined cross-referenced logs and traces.
So right now you have to use one logrotate file, another for tmpwarch
and yet another for the compression. And be sure all of them match at
all times, since the stuff is cross referenced. This is an admin's
nightmare)
Comment 4 Elliot Lee 2004-06-02 13:36:14 EDT
I don't want to let this report sit here and pretend that anything is
going to happen with it. A patch would be harder to argue with, but
it's not likely that I'll ever make time to code the feature, given
other priorities.
Comment 5 Nicolas Mailhot 2004-06-02 14:33:34 EDT
That's fair if not exactly welcome

Note You need to log in before you can comment on or make changes to this bug.