Bug 109638 - ntptrace missing
ntptrace missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 10:31 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 09:15:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-11-10 10:31:20 EST
Description of problem:
For some reason, the version of ntp in FC-1 explicitly deletes
ntptrace (no explanation in changelog).

I find this a useful utility and a bug that it is deleted.
Comment 1 Wojciech Kazubski 2003-12-09 07:04:43 EST
ntptrace was deleted in line 145 of ntp.spec.
Is this connected with trials of the new version of ntp-4.2.0?
The file can be restored by rebuilding ntp with the above line deleted
or ommented out (works for me on i386 platform).
If ntptrace was deleted intentionally, please state the replacement
command in the package description.
The man page should be also removed or replaced with current information.
Comment 2 Gene Czarcinski 2003-12-09 09:47:24 EST
Yes, it does appear it was deleted because of ntp-4.2.0.

While ntptrace in ntp-4.1.2 is a "c" program, it is a perl script in
ntp-4.2.0.  I can understand the reluctance of requiring (pulling in)
perl on a minimal system just so that the full ntp package is supported.

My sugestion to "have our cake and eat it too" is to split the ntp
package into (perhaps) an ntp and an ntp-perlscripts (or something). 
That way, a minimal install would not pull in perl and yet the scripts
would be available for those that want/need them.
Comment 3 Gene Czarcinski 2003-12-18 14:26:04 EST
It may not matter if the ntp package requires perl or not.

The logwatch package is part of a "minimal" install and it requires perl.
Comment 4 Bart Martens 2003-12-28 08:39:26 EST
Of course, ntptrace should still have been included in ntp-4.1.2-5.
Note that the man page of ntptrace is still included while ntptrace
itself is not.
Comment 5 Harald Hoyer 2004-01-28 09:15:36 EST
reappears in ntp-4.2.0-5

Note You need to log in before you can comment on or make changes to this bug.