Bug 109651 - eclipse build omits platform source
eclipse build omits platform source
Status: CLOSED NEXTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: Tom Tromey
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 12:57 EST by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-11 13:38:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Tromey 2003-11-10 12:57:45 EST
The eclipse build omits the platform source components.
If you look in
/usr/lib/eclipse/plugins/org.eclipse.platform.source_2.1.1/,
you'll see it is mostly empty.  Instead it should have
a subdirectory holding a lot of source components.

This is a problem because the missing components include
XML schema for parts of plugin.xml.  Without these, the
PDE plugin.xml editor can't properly edit certain extension
points.

Also, you can observe an unexpected exception and subsequent
strange behavior by trying to open the properties view of
an extension point in the plugin.xml editor.  I believe this
is related to this problem.
Comment 1 Tom Tromey 2003-11-10 17:57:41 EST
I'm handling this one.
Comment 2 Tom Tromey 2003-11-10 21:43:53 EST
I've checked in a fix for this.
Will verify with next snapshot RPM.
Comment 3 John Healy 2004-03-08 16:26:43 EST
Moving from RHEL/3/Eclipse to Red Hat Developer Suite product.

Note You need to log in before you can comment on or make changes to this bug.