Bug 109654 - ogg123 -d oss displays junk or dies badly if ^C hit very early
ogg123 -d oss displays junk or dies badly if ^C hit very early
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: vorbis-tools (Show other bugs)
2
All Linux
low Severity low
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 13:46 EST by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 11:59:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2003-11-10 13:46:00 EST
^C ogg123 very early and you will see


Audio Device:   OSS audio driver output
 
Time: -35791394:  nan [-35791394:  nan] of -35791394:  inf  (  0.0
kbps)  Output                                                        
                                                                     
                                  
Done.

rather than the line being properly suppressed if no output has occurred
Comment 1 Colin Walters 2004-09-21 22:23:50 EDT
I can't reproduce, seems to have been fixed.
Comment 2 Alan Cox 2004-09-22 08:26:48 EDT
Its still there in FC1, FC2 uses the ALSA backend by default. If you
use the OSS backend (-d OSS) you will find early ^C causes variously
hangs and garbage output even in FC2. If you have trouble reproducing
it use a slowish box, you probably won't manage to reproduce it on
some 2Ghz box while it is easy to do on a PII/233

ALSA code path seems to be fine so its now a very low priority issue.
Comment 3 Colin Walters 2004-09-22 11:59:45 EDT
Moved upstream:
http://bugs.xiph.org/show_bug.cgi?id=573

Note You need to log in before you can comment on or make changes to this bug.