Bug 1096574 - gc make check fails on test_stack for ppc64le arch
Summary: gc make check fails on test_stack for ppc64le arch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libatomic_ops
Version: 22
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Pavel Raiskup
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 883748
TreeView+ depends on / blocked
 
Reported: 2014-05-12 04:24 UTC by Michel Normand
Modified: 2016-04-09 14:23 UTC (History)
5 users (show)

Fixed In Version: libatomic_ops-7.4.2-9.fc24 libatomic_ops-7.4.2-9.fc22 libatomic_ops-7.4.2-9.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-02 15:55:38 UTC


Attachments (Terms of Use)
gc-ppc64le_force_AO_load.patch (1.02 KB, patch)
2014-05-12 04:24 UTC, Michel Normand
no flags Details | Diff

Description Michel Normand 2014-05-12 04:24:57 UTC
Created attachment 894543 [details]
gc-ppc64le_force_AO_load.patch

Description of problem: gc make check for ppc64le archi


Version-Release number of selected component (if applicable):
gc-7.2e-2.fc21

How reproducible:


Steps to Reproduce:
1. fedpkg clone -a gc
2. fedpkg mockbuild

Actual results:
http://ppc-le.koji.fedoraproject.org/kojifiles/work/tasks/4826/14826/build.log
===
make  check-TESTS
make[3]: Entering directory `/builddir/build/BUILD/gc-7.2/libatomic_ops/tests'
make[4]: Entering directory `/builddir/build/BUILD/gc-7.2/libatomic_ops/tests'
PASS: test_atomic
PASS: test_atomic_pthreads
../test-driver: line 107: 17252 Aborted                 "$@" > $log_file 2>&1
FAIL: test_stack
PASS: test_malloc
===


Additional info:
the attached gc-ppc64le_force_AO_load.patch is solving the problem.

Comment 1 Pavel Raiskup 2014-05-12 08:47:19 UTC
Michel, thanks for the patch.  I checked upstream mailing list and I saw some
discussion about this patch around February.  No patch is committed to git 
yet, iirc.

I was trying to resolve the rhbz#883748 some time ago and that issue seems to
be the same, isn't it?

I need to know whether this issue blocks you somehow (some other package
requiring atomic ops which you want to fix for ppc64le, etc.).  Otherwise,
I would rather go the upstream-first way as we do not hurry.

Comment 2 Michel Normand 2014-05-12 10:08:54 UTC
(In reply to Pavel Raiskup from comment #1)
> [Cut] ...
>
> I was trying to resolve the rhbz#883748 some time ago and that issue seems to
> be the same, isn't it?

yes
 
> I need to know whether this issue blocks you somehow (some other package
> requiring atomic ops which you want to fix for ppc64le, etc.).  Otherwise,
> I would rather go the upstream-first way as we do not hurry.

the problem is blocking ppc64le except if gc package set again with "make_check" tag on ppc-le koji http://ppc-le.koji.fedoraproject.org/koji/packages?tagID=4 (tag used to avoid to trigger make check).

Comment 3 Rex Dieter 2014-05-12 12:18:14 UTC
I can at least implement 'make check' be non-fatal on ppc64le too, until some upstreamable solution is found.

Comment 4 Rex Dieter 2014-05-12 12:30:48 UTC
%changelog
* Mon May 12 2014 Rex Dieter <rdieter@fedoraproject.org> 7.2e-3
- 'make check' non-fatal on ppc64le too (#1096574)

gc-7.3e-3 build should at least finish now on ppc64le

Comment 5 Rex Dieter 2014-05-12 12:43:37 UTC
As an aside, *if* upstream fixes this, would be nice to be able to update to latest gc-7.4+, see bug #1039345  , if you want to help out there.

Comment 6 Pavel Raiskup 2014-05-12 13:24:49 UTC
Note for me: AO_load is defined to not contain barrier (fix should be stack
feature only):
  https://lists.opendylan.org/pipermail/bdwgc/2014-February/005853.html

Comment 7 Pavel Raiskup 2014-05-13 20:07:26 UTC
The libatomic_ops will be separate package (#1038167).

Comment 8 Michel Normand 2014-08-21 10:16:57 UTC
(In reply to Rex Dieter from comment #4)
> %changelog
> * Mon May 12 2014 Rex Dieter <rdieter@fedoraproject.org> 7.2e-3
> - 'make check' non-fatal on ppc64le too (#1096574)
> 
> gc-7.3e-3 build should at least finish now on ppc64le

the bypass is done now since libatomic_ops 7.4.2-1 to ignore make check error
so remove the blocker of rhbz#1051573

Comment 9 Jaroslav Reznik 2015-03-03 17:01:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 10 Fedora Update System 2016-03-28 14:03:04 UTC
libatomic_ops-7.4.2-9.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7c84bec82f

Comment 11 Fedora Update System 2016-03-28 14:17:07 UTC
libatomic_ops-7.4.2-9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4b4387d2e4

Comment 12 Fedora Update System 2016-03-28 14:17:46 UTC
libatomic_ops-7.4.2-9.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9f645ae455

Comment 13 Fedora Update System 2016-03-28 20:49:22 UTC
libatomic_ops-7.4.2-9.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9f645ae455

Comment 14 Fedora Update System 2016-03-28 20:49:23 UTC
libatomic_ops-7.4.2-9.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4b4387d2e4

Comment 15 Fedora Update System 2016-03-28 20:54:50 UTC
libatomic_ops-7.4.2-9.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7c84bec82f

Comment 16 Fedora Update System 2016-04-02 15:55:33 UTC
libatomic_ops-7.4.2-9.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-04-09 14:22:52 UTC
libatomic_ops-7.4.2-9.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-04-09 14:23:51 UTC
libatomic_ops-7.4.2-9.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.