Bug 1096587 - Architecture conflict between i686 and x86_64
Summary: Architecture conflict between i686 and x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nordugrid-arc
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL: https://bugzilla.nordugrid.org/show_b...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-12 06:10 UTC by George R. Goffe
Modified: 2014-09-08 16:07 UTC (History)
1 user (show)

Fixed In Version: nordugrid-arc-doc-1.5.0-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-30 03:53:13 UTC


Attachments (Terms of Use)

Description George R. Goffe 2014-05-12 06:10:20 UTC
Description of problem:

Transaction check error:
  file /usr/libexec/arc/DataStagingDelivery conflicts between attempted installs of nordugrid-arc-4.1.0-1.fc19.i686 and nordugrid-arc-4.1.0-1.fc19.x86_64
  file /usr/libexec/arc/arc-file-access conflicts between attempted installs of nordugrid-arc-4.1.0-1.fc19.i686 and nordugrid-arc-4.1.0-1.fc19.x86_64

Version-Release number of selected component (if applicable):

see above

How reproducible:

always

Steps to Reproduce:
1.yum update
2.
3.

Actual results:

see additional info

Expected results:

Successful update

Additional info:

Loaded plugins: aliases, auto-update-debuginfo, changelog, fastestmirror, filter-data, fs-snapshot, keys, langpacks, list-data, local, merge-conf, post-transaction-actions, priorities,
              : protectbase, ps, puppetverify, refresh-packagekit, refresh-updatesd, remove-with-leaves, rpm-warm-cache, show-leaves, tmprepo, tsflags, upgrade-helper, verify, versionlock
Loading mirror speeds from cached hostfile
 * fedora: mirrors.kernel.org
 * fedora-debuginfo: mirrors.kernel.org
 * fedora-source: mirrors.kernel.org
 * updates: mirror.prgmr.com
 * updates-debuginfo: mirrors.kernel.org
Skipping filters plugin, no data
0 packages excluded due to repository protections
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package nordugrid-arc.x86_64 0:4.0.0-1.fc19 will be updated
---> Package nordugrid-arc.i686 0:4.1.0-1.fc19 will be obsoleting
--> Processing Dependency: libxmlsec1.so.1 for package: nordugrid-arc-4.1.0-1.fc19.i686
--> Processing Dependency: libxmlsec1-openssl.so.1 for package: nordugrid-arc-4.1.0-1.fc19.i686
---> Package nordugrid-arc.x86_64 0:4.1.0-1.fc19 will be obsoleting
---> Package nordugrid-arc-ca-utils.noarch 0:4.0.0-1.fc19 will be updated
---> Package nordugrid-arc-ca-utils.noarch 0:4.1.0-1.fc19 will be an update
---> Package nordugrid-arc-doxygen.noarch 0:3.0.3-2.fc19 will be obsoleted
---> Package nordugrid-arc-gridmap-utils.noarch 0:4.0.0-1.fc19 will be updated
---> Package nordugrid-arc-gridmap-utils.noarch 0:4.1.0-1.fc19 will be an update
---> Package nordugrid-arc-misc-utils.x86_64 0:4.0.0-1.fc19 will be updated
---> Package nordugrid-arc-misc-utils.x86_64 0:4.1.0-1.fc19 will be an update
---> Package nordugrid-arc-plugins-needed.x86_64 0:4.0.0-1.fc19 will be updated
---> Package nordugrid-arc-plugins-needed.x86_64 0:4.1.0-1.fc19 will be an update
--> Running transaction check
---> Package xmlsec1.i686 0:1.2.18-4.fc19 will be installed
---> Package xmlsec1-openssl.i686 0:1.2.18-4.fc19 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================
 Package                                                      Arch                                   Version                                          Repository                              Size
===================================================================================================================================================================================================
Installing:
 nordugrid-arc                                                i686                                   4.1.0-1.fc19                                     _local                                 1.5 M
     replacing  nordugrid-arc-doxygen.noarch 3.0.3-2.fc19
 nordugrid-arc                                                x86_64                                 4.1.0-1.fc19                                     _local                                 1.5 M
     replacing  nordugrid-arc-doxygen.noarch 3.0.3-2.fc19
Updating:
 nordugrid-arc-ca-utils                                       noarch                                 4.1.0-1.fc19                                     _local                                 6.9 k
 nordugrid-arc-gridmap-utils                                  noarch                                 4.1.0-1.fc19                                     _local                                  25 k
 nordugrid-arc-misc-utils                                     x86_64                                 4.1.0-1.fc19                                     _local                                 139 k
 nordugrid-arc-plugins-needed                                 x86_64                                 4.1.0-1.fc19                                     _local                                 1.3 M
Installing for dependencies:
 xmlsec1                                                      i686                                   1.2.18-4.fc19                                    _local                                 160 k
 xmlsec1-openssl                                              i686                                   1.2.18-4.fc19                                    _local                                  66 k

Transaction Summary
===================================================================================================================================================================================================
Install  2 Packages (+2 Dependent packages)
Upgrade  4 Packages

Total download size: 4.8 M
Downloading packages:
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                               13 MB/s | 4.8 MB  00:00:00     
Running transaction check
Running transaction test


Transaction check error:
  file /usr/libexec/arc/DataStagingDelivery conflicts between attempted installs of nordugrid-arc-4.1.0-1.fc19.i686 and nordugrid-arc-4.1.0-1.fc19.x86_64
  file /usr/libexec/arc/arc-file-access conflicts between attempted installs of nordugrid-arc-4.1.0-1.fc19.i686 and nordugrid-arc-4.1.0-1.fc19.x86_64

Error Summary
-------------

rpm -qa | grep nordugrid-arc | sort

nordugrid-arc-4.0.0-1.fc19.x86_64
nordugrid-arc-ca-utils-4.0.0-1.fc19.noarch
nordugrid-arc-doxygen-3.0.3-2.fc19.noarch
nordugrid-arc-gridmap-utils-4.0.0-1.fc19.noarch
nordugrid-arc-misc-utils-4.0.0-1.fc19.x86_64
nordugrid-arc-plugins-needed-4.0.0-1.fc19.x86_64

Comment 1 Fedora Update System 2014-08-20 11:59:19 UTC
nordugrid-arc-doc-1.5.0-1.el5,nordugrid-arc-4.2.0-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/nordugrid-arc-doc-1.5.0-1.el5,nordugrid-arc-4.2.0-1.el5

Comment 2 Fedora Update System 2014-08-20 11:59:33 UTC
nordugrid-arc-doc-1.5.0-1.fc20,nordugrid-arc-4.2.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/nordugrid-arc-doc-1.5.0-1.fc20,nordugrid-arc-4.2.0-1.fc20

Comment 3 Fedora Update System 2014-08-20 11:59:41 UTC
nordugrid-arc-doc-1.5.0-1.el6,nordugrid-arc-4.2.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/nordugrid-arc-doc-1.5.0-1.el6,nordugrid-arc-4.2.0-1.el6

Comment 4 Fedora Update System 2014-08-20 11:59:51 UTC
nordugrid-arc-doc-1.5.0-1.fc19,nordugrid-arc-4.2.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nordugrid-arc-doc-1.5.0-1.fc19,nordugrid-arc-4.2.0-1.fc19

Comment 5 Fedora Update System 2014-08-20 22:59:32 UTC
Package nordugrid-arc-doc-1.5.0-1.el6, nordugrid-arc-4.2.0-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing nordugrid-arc-doc-1.5.0-1.el6 nordugrid-arc-4.2.0-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2263/nordugrid-arc-doc-1.5.0-1.el6,nordugrid-arc-4.2.0-1.el6
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-08-30 03:53:13 UTC
nordugrid-arc-doc-1.5.0-1.fc20, nordugrid-arc-4.2.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-08-30 03:53:53 UTC
nordugrid-arc-doc-1.5.0-1.fc19, nordugrid-arc-4.2.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-09-08 16:07:43 UTC
nordugrid-arc-doc-1.5.0-1.el5, nordugrid-arc-4.2.0-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-09-08 16:07:52 UTC
nordugrid-arc-doc-1.5.0-1.el6, nordugrid-arc-4.2.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.