Bug 109671 - RFE: Need to support USB ADSL modems
RFE: Need to support USB ADSL modems
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks: 87718 131554
  Show dependency treegraph
 
Reported: 2003-11-10 15:52 EST by Jean Francois Martinez
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 06:15:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Francois Martinez 2003-11-10 15:52:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
The utility should be extended to support USB-based ADSL modems.

USB-based ADSL modems are popular and cheap, several popular ones are
supported by Linux.  But the redhat-config-network utility lets you on
your own and doesn't help at all with them.  It only supports
ethernet-based ADSL modems.  But given that they are more expensive
and that many people have USB-based modems provided by their ISP not
supporting USB-based modems is a serious shortcoming for
redhat-config-network

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Not applicable
2.
3.
    

Additional info:
Comment 1 Eddahbi Karim 2004-09-28 12:02:58 EDT
The problem is : If there's no standard way to connect via these USB
modems, the support will be hard to add and maintain.

The way should be :

- Launch the appropriate command to load the firmware
- Connect via pppoa or pppoe (if there's a bridge tool)

With this structure, I've some ideas about how network-druid could be
modified.

An option would be added : xDSL via USB Modems connection would be added.

Clicking on 'Next' would lead to a text which would inform the user
than he must install the appropriate tools for his modem and where to
find these tools (For example, using {redhat,system}-config-packages,
then looking into the 'modem' category)

The next step will lead to a configuration window.

Following a description of the window :
- A dropdown menu will present some USB modems (Sagem F@st
800/900/908/ -- Alcatel Speedtouch USB -- Bewan USB ...). These
options would define the way to load the firmware.

- Another dropdown menu below will show different country and ISP,
those defining the VPI/VCI to use. The last option would be 'User
defined VPI/VCI' which will let the user enter his own VPI/VCI numbers
in two small text areas.

- Then, the user will enter his/her login/password, given by his/her
ISP, in two large text areas.

After this, the configuration will be finished and the network tool
will be able to launch the connection, loading the firmware before, if
necessary.

There's still a problem : How tools are added to the system ? Must the
user install the tools himself ? How
{redhat,system}-config-network-druid will know anything about what
tools are installed ?

A solution would be, taking the Speedtouch USB tools for example : The
speedtouch RPM will install the necessary tools and write to a file,
it's name in the dropdown menu, how and what firmware is loaded, then
the network-druid could read this file to get the necessary informations.

Another problem bring its nose : Some firmware are proprietary. If we
stick to free software, the firmware can't be added neither to the
official Fedora tree neither in the official ISOs. It can lead to some
problems, forcing the user to download the firmware elsewhere but the
firmware is absolutely necessary to bring the connection up and
download the firmware. So... I haven't any good solutions for this
problem.

The last problem will be : Find a nice way to bring up the connection
with every USB modem. That will be a bit difficult.
Comment 2 Need Real Name 2005-01-09 11:25:14 EST
I'm a USB SpeedTouch-clone user in China available to help test
developments until at least April this year.

PS: With Chinese support (not quite automatically) there in FC3, and
China's massive DSL rollouts (both PPPoE and PPPoA), adding this
feature to Fedora could mean a great payoff in terms of potential new
users.

PPS: On the firmware issue, I believe some modems have firmware
extract utilities(?), so if it's just a case of take & reload, perhaps
these may be workable as a licensing kludge.  Otherwise prompting the
user for a firmware file (but letting them supply a URL instead, in
the same box) is another suggestion, which would ease the
user-experience (search google, copy, paste) while avoiding licensing.

Note You need to log in before you can comment on or make changes to this bug.