Bug 1096777 - bad URI error while trying to remove subscriptions using subscription-manager --serial <serial>
Summary: bad URI error while trying to remove subscriptions using subscription-manager...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: William Poteat
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-05-12 12:21 UTC by Shwetha Kallesh
Modified: 2014-10-14 07:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:46:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Shwetha Kallesh 2014-05-12 12:21:09 UTC
Description of problem:
 bad URI error while trying to remove subscriptions using subscription-manager --serial <serial> 

Version-Release number of selected component (if applicable):
[root@shwetha-workstation ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 1.5.0-19.el6sat-Katello
subscription-manager: 1.11.6-1.git.0.9c712b7.el6
python-rhsm: 1.11.4-1.git.0.3536b12.el6
 

How reproducible:


Steps to Reproduce:
[root@shwetha-workstation ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS with up to 4 virtual guests
Provides:          Awesome OS Server Bits
SKU:               awesomeos-virt-4
Contract:          4
Account:           12331131231
Serial:            3377641380824596814
Pool ID:           8ac149f445aea4490145aead2883021e
Active:            True
Quantity Used:     1
Service Level:    
Service Type:      
Status Details:    
Subscription Type: Multi-Entitleable
Starts:            04/22/2014
Ends:              04/22/2015
System Type:       Physical
 
Subscription Name: Awesome OS with up to 4 virtual guests
Provides:          Awesome OS Server Bits
SKU:               awesomeos-virt-4
Contract:          4
Account:           12331131231
Serial:            3482872516714389125
Pool ID:           8ac149f445aea4490145aead2883021e
Active:            True
Quantity Used:     1
Service Level:    
Service Type:      
Status Details:    
Subscription Type: Multi-Entitleable
Starts:            04/22/2014
Ends:              04/22/2015
System Type:       Physical
 
[root@shwetha-workstation ~]# subscription-manager remove --serial 8ac149f445aea4490145aead2883021e
Error: '8ac149f445aea4490145aead2883021e' is not a valid serial number
[root@shwetha-workstation ~]# subscription-manager remove --serial 3482872516714389125
Serial numbers unsuccessfully removed at the server:
   bad URI(is not URI?): https://localhost:8443/candlepin/consumers/consumer:%20name="shwetha-workstation",%20uuid=76824cb5-22f8-4212-a91a-bfcef5680300/certificates/3482872516714389125

[root@shwetha-workstation ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS with up to 4 virtual guests
Provides:          Awesome OS Server Bits
SKU:               awesomeos-virt-4
Contract:          4
Account:           12331131231
Serial:            3377641380824596814
Pool ID:           8ac149f445aea4490145aead2883021e
Active:            True
Quantity Used:     1
Service Level:    
Service Type:      
Status Details:    
Subscription Type: Multi-Entitleable
Starts:            04/22/2014
Ends:              04/22/2015
System Type:       Physical
 
Subscription Name: Awesome OS with up to 4 virtual guests
Provides:          Awesome OS Server Bits
SKU:               awesomeos-virt-4
Contract:          4
Account:           12331131231
Serial:            3482872516714389125
Pool ID:           8ac149f445aea4490145aead2883021e
Active:            True
Quantity Used:     1
Service Level:    
Service Type:      
Status Details:    
Subscription Type: Multi-Entitleable
Starts:            04/22/2014
Ends:              04/22/2015
System Type:       Physical

Actual results:


Expected results:


Additional info:

Comment 2 William Poteat 2014-05-21 18:39:57 UTC
commmit 913519015dccb0ea0606274cef23233e465eaaa6

Comment 4 Shwetha Kallesh 2014-07-03 15:32:02 UTC
[root@dhcp-0-177 ~]# subscription-manager version
server type: RHN Classic and Red Hat Subscription Management
subscription management server: 0.9.20-1
subscription management rules: 5.10
subscription-manager: 1.12.6-1.el6
python-rhsm: 1.12.3-1.el6


[root@dhcp-0-177 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS Instance Based (Standard Support)
Provides:          Awesome OS Instance Server Bits
SKU:               awesomeos-instancebased
Contract:          1
Account:           12331131231
Serial:            3537497260865297486
Pool ID:           0000000046e324020146e325670c091e
Active:            True
Quantity Used:     4
Service Level:     Standard
Service Type:      L1-L3
Status Details:    
Subscription Type: Instance Based
Starts:            06/28/2014
Ends:              06/28/2015
System Type:       Physical

[root@dhcp-0-177 ~]# subscription-manager remove --serial 3537497260865297486
Serial numbers successfully removed at the server:
   3537497260865297486
1 local certificate has been deleted.
[root@dhcp-0-177 ~]# subscription-manager list --consumed
No consumed subscription pools to list

Comment 5 errata-xmlrpc 2014-10-14 07:46:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.