Bug 1096849 - docker daemon for epel7 doesn't allow for additional options
Summary: docker daemon for epel7 doesn't allow for additional options
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: docker-io
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-12 14:16 UTC by Jim Perrin
Modified: 2014-07-01 23:00 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-11 13:22:41 UTC


Attachments (Terms of Use)

Description Jim Perrin 2014-05-12 14:16:27 UTC
Description of problem:
For el6, epel's docker build creates /etc/sysconfig/docker, which allows other options to be passed to the docker daemon. the systemd unit files for epel7's docker build do not. 

Version-Release number of selected component (if applicable):
docker-io-0.10.0-2.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install docker-io
2. less /usr/lib/systemd/system/docker.service

Actual results:
There is no $other_args defined in the systemd unit file, nor is there an /etc/sysconfig/docker in which to define the options. 

Expected results:
Same as the el6 docker. You should be able to pass additional arguments for bridging, dns, or restart options 

Additional info:

Comment 1 Jim Perrin 2014-05-12 15:09:41 UTC
After poking around systemd a bit more, it appears that this can be done systemd internals by creating /etc/systemd/system/docker.service.d/bridge.conf or similar with the options I need. This option doesn't appear to be documented well, but it seems to work fine and be the 'proper' way.

Comment 2 Daniel Walsh 2014-05-22 16:21:49 UTC
Jim can you document this?  So we can add it to the docker package?   Should we add a  /etc/systemd/system/docker.service.d/ to the docker package?

Comment 3 Jim Perrin 2014-05-23 19:52:51 UTC
I'll try to document something sane for this. 

I'm not certain that adding the directory to the package is 'proper', as no other packages appear to provide similar directories. It's possible it should simply go into /usr/share/doc/docker-io-*/ as an options example file.

Comment 4 Daniel Walsh 2014-05-24 09:23:47 UTC
OK that sounds good.  BTW In rhel7 the package will be called docker not docker-io.  Which I wish we would fix in Fedora and RHEL6/Centos6.

Comment 5 Edouard Bourguignon 2014-06-11 09:54:33 UTC
I can't find any docker package on rhel7. docker-io is there (version 1.0.0-1.el7) but /etc/sysconfig/docker seems to be an HTML page...
I'll check the docs in /usr/share/doc/docker-io*

And I can't use any more (it seems) the HTTP_PROXY env variable. docker tries to resolv docker.io...

Comment 7 Daniel Walsh 2014-06-11 12:27:59 UTC
You need to enable the extras repo.

I think you do this via  

# subscription-manager repos --enable=rhel-x86_64-server-extras-7
# subscription-manager repos --enable=rhel-x86_64-server-optional-7

Comment 13 Daniel Walsh 2014-06-11 13:22:41 UTC
This package is being removed from EPEL since there is now a supported version of docker in the released rhel7 repositories.


Note You need to log in before you can comment on or make changes to this bug.