Bug 109687 - can not umount cdrom
can not umount cdrom
Status: CLOSED DUPLICATE of bug 106936
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 18:24 EST by Ignacio Galmarino
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Galmarino 2003-11-10 18:24:14 EST
Description of problem:

when you insert a cdrom its automounted but when you try to umount it
you get an error message "cdrom is busy"

Fedora Core 1 on i686


How reproducible:


Steps to Reproduce:
1. Boot Fedora (Gnome)
2. Insert a cdrom in the cdrom drive
3. click on the cdrom icon and select eject
  
Additional info:

i change the inittab to "id:3:initdefault:" to boot on text mode (also
remove rhgb on grub.conf). Loging using a standar user. Startx and
everything works OK
Comment 1 Miloslav Trmac 2003-11-11 06:22:18 EST
Seen here too, it seems fam holding open files there again :(
Comment 2 Nick Marsh 2003-11-23 18:29:17 EST
Obligatory "me too". If I use the command line to mount a cd or dvd
from inside Gnome, I cannot umount it unless I change runlevels or reboot.
Comment 3 Nick Marsh 2003-11-27 03:45:17 EST
Here is how you can see what files were open. The only question now is
why were the files open even though I had already closed them? Perhaps
there is something wrong with file locks and read only file systems on
Fedora (just a guess)?

$ umount -v /dev/cdrom
umount: /mnt/cdrom: device is busy

$ /usr/sbin/lsof|grep cdrom
fam       3376  nmarsh   31r   DIR      22,64     2588       269
/mnt/cdrom/VIDEO_TS

Note: I was *not* in /mnt/cdrom/VIDEO_TS anymore.

# umount -vf /dev/cdrom
umount2: Device or resource busy
umount: /mnt/cdrom: device is busy

# kill 3376

# umount -v /dev/cdrom
/dev/cdrom umounted
Comment 4 Rene 2003-12-04 22:58:43 EST
Can't wait till this is fixed. Was trying to show a pal how 'easy'
desktop linux can be when we got bit by this bug...hehe.  = )
Comment 5 Carlos Rodrigues 2003-12-18 19:39:24 EST
I guess this is a duplicate for Bug #106936.
Comment 6 Alexander Larsson 2004-02-04 06:17:44 EST

*** This bug has been marked as a duplicate of 106936 ***
Comment 7 Martin Nielsen 2004-06-03 15:05:24 EDT
From KDE desktop (as root), installed rpm fam-2.6.10-9.  To unmount
and eject cd disk, go to Start Applications (red fedora) > system
tools > disk management > high lite cd-rom and click on "unmount". 
Drive will unmount and disk will eject.  This works.  If just the
eject button on the cd-rom drive is pushed, then a busy lite on the
drive will show and disk will not eject.
Comment 8 Carlos Rodrigues 2004-06-04 09:24:42 EDT
The eject button on the drive is disabled while the drive is mounted
(the drive is locked). This is normal behavior for all drive types
that support it (cdroms, zips, ...).

Well, using the disk management tool works, but isn't it easier just
to right-click on the cdrom icon, select unmount and then press the
eject button to eject it?
Comment 9 Red Hat Bugzilla 2006-02-21 13:59:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.