Bug 1096902 - "Maximum" and "Minimum" values do not match the graph values
Summary: "Maximum" and "Minimum" values do not match the graph values
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.2.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: DR03
: JON 3.2.2
Assignee: Jirka Kremser
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On: 1096908
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-12 16:01 UTC by bkramer
Modified: 2018-12-05 18:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 00:17:33 UTC
Type: Bug


Attachments (Terms of Use)
DR3 Graph Snapshot (67.17 KB, image/png)
2014-07-01 14:53 UTC, Matt Mahoney
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 882113 None None None Never

Description bkramer 2014-05-12 16:01:00 UTC
Description of problem:
When selecting a specific monitoring graph in some time frames the graph is non consistent with the textual values given.

Clearly the "Maximum" shown does not match with what you can see in the graph. If we hover above the maximum points far bigger values are shown than in the textual representation above the graph.

If this time frame is selected NO errors or exceptions are logged in the server logs or in the Web-UI.

Version-Release number of selected component (if applicable):
JBoss ON 3.2.1

How reproducible:
Very often

Steps to Reproduce:
1. Navigate to the JON UI -> Monitoring -> Metrics and check the textual values for Minimum and Maximum as well as the values in the corresponding graph. 
2. If the issue is not visible, change the time period that should be captured in the graph and check the values again.
3.

Actual results:
Text maximum value shows different value then the Maximum value in the graph. For instance, text Maximum value shows 8.6G while it is clear (from the screenshot) that this value is more then 10G.

Expected results:
The correct Min and Max values are written in both graph and outside of the graph.


Additional info:

Comment 2 Jirka Kremser 2014-06-24 17:17:31 UTC
71b927358 in master (waiting for the cherry-picking)

Mike, could you review, please?

Comment 3 Mike Thompson 2014-06-25 23:55:51 UTC
Cherry-pick Committed to release/jon3.2.x

Adjustments were made because of out of date branch.

[BZ 1096902] - "Maximum" and "Minimum" values do not match the graph values - fixing a race condition in CustomDateRangeState

(cherry picked from commit 71b927358b997627375703a3510a2f03bbfb0c3c) Signed-off-by: Mike Thompson <mithomps@redhat.com>

Conflicts:
	modules/enterprise/gui/coregui/src/main/java/org/rhq/coregui/client/inventory/resource/detail/monitoring/table/MetricsViewDataSource.java
	A ../../../modules/enterprise/gui/coregui/src/main/java/org/rhq/coregui/client/inventory/resource/detail/monitoring/table/MetricsGridFieldName.java
     M ../../../modules/enterprise/gui/coregui/src/main/java/org/rhq/coregui/client/inventory/resource/detail/monitoring/table/MetricsTableView.java
     M ../../../modules/enterprise/gui/coregui/src/main/java/org/rhq/coregui/client/inventory/resource/detail/monitoring/table/MetricsViewDataSource.java
     M ../../../modules/enterprise/gui/coregui/src/main/resources/org/rhq/coregui/client/Messages.properties
     M ../../../modules/enterprise/gui/coregui/src/main/resources/org/rhq/coregui/client/Messages_cs.properties
     M ../../../modules/enterprise/gui/coregui/src/main/resources/org/rhq/coregui/client/Messages_de.properties
     M ../../../modules/enterprise/gui/coregui/src/main/resources/org/rhq/coregui/client/Messages_ja.properties
     M ../../../modules/enterprise/gui/coregui/src/main/resources/org/rhq/coregui/client/Messages_ko.properties
     M ../../../modules/enterprise/gui/coregui/src/main/resources/org/rhq/coregui/client/Messages_pt.properties
     M ../../../modules/enterprise/gui/coregui/src/main/resources/org/rhq/coregui/client/Messages_ru.properties
     M ../../../modules/enterprise/gui/coregui/src/main/resources/org/rhq/coregui/client/Messages_zh.properties

Comment 4 Simeon Pinder 2014-06-30 06:03:10 UTC
Moving to ON_QA as available for test in latest build:
http://jon01.mw.lab.eng.bos.redhat.com:8042/dist/release/jon/3.2.2.GA/6-28-2014/

Comment 5 Matt Mahoney 2014-07-01 14:53:40 UTC
Created attachment 913785 [details]
DR3 Graph Snapshot

Comment 6 Larry O'Leary 2014-07-29 00:17:33 UTC
This has been verified and released in Red Hat JBoss Operations Network 3.2 Update 02 (3.2.2) available from the Red Hat Customer Portal[1].



[1]: https://access.redhat.com/jbossnetwork/restricted/softwareDetail.html?softwareId=31783


Note You need to log in before you can comment on or make changes to this bug.