Bug 109691 - Fedora Core 1 Mozilla PPC binaries were built with x86 flags
Fedora Core 1 Mozilla PPC binaries were built with x86 flags
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 19:02 EST by Joel Barrios
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-02 16:34:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Barrios 2003-11-10 19:02:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031102 Epiphany/1.0.4

Description of problem:
After installing PPC packages from Fedora in an iMac DV (I just avoided
initscripts, devlabel, gpm and mkinitrd), I was wondering why everything
worked fine except for mozilla/epiphany. I even rebuilt from SRPMs
several 1.4.1 SRPMs releases with 100% of negative results, until I
examined the mozilla spec file and found out why Fedora's mozilla RPMs
for PPC are broken:

# build mozilla - XCFLAGS is for NSS which can't use CFLAGS for
# various reasons
%ifarch ia64
OPTFLAGS=-O0
%else
OPTFLAGS=-O2
%endif

                                                            
XCFLAGS=-g
CFLAGS=-g
%ifarch ia64
CXXFLAGS="-fno-inline -g"
%else
CXXFLAGS=-g
%endif

Guess the PPC mozilla packages were built just doing rpmbuild --rebuild.
So, <http://ftp.redhat.com/pub/redhat/linux/rawhide/ppc/Fedora/RPMS/>
has mozilla _PPC_ binary pacakges built with OPTFLAGS=-O2 and
CXXFLAGS=-g (!?!).

After removing these lines from the spec file, that really should
consider other architectures, and doing rpmbuild -bb, I could
successfully build mozilla packages that actually _work_ on PPC.

I reported this two weeks ago in fedora-test-list. Gues I should have
done it here in the first place.

Version-Release number of selected component (if applicable):
mozilla-1.4.1-17

How reproducible:
Always

Steps to Reproduce:
1. Install mozilla pakages for PPC on a PPC computer
2. run mozilla, it will surely crash

    

Actual Results:  Crash

Expected Results:  Run mozilla

Additional info:
Comment 1 Paul Nasrat 2003-11-17 02:10:22 EST
I made the minor spec change:

%ifarch ia64 ppc

Probably needs to have sparc there too

Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.4.1) Gecko/2003110

See following post for more details:

http://www.redhat.com/archives/fedora-test-list/2003-November/msg00200.html

Which links to following gcc bugzilla entry:

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=11376


Comment 2 Paul Nasrat 2003-11-18 11:33:08 EST
Just to reclarify mozilla on ppc will fail with -O2 trivial fix as
ia64 needed due to optimisation fun and games (as linked to above)

Comment 3 Christopher Blizzard 2003-12-02 16:34:29 EST
Merged into the head.  This will be part of the next build.

Note You need to log in before you can comment on or make changes to this bug.