Bug 109693 - SMP kernel locks up the machine. Single processor kernel works
SMP kernel locks up the machine. Single processor kernel works
Status: CLOSED DUPLICATE of bug 107880
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-11-10 19:32 EST by Rob Kypriotakis
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rob Kypriotakis 2003-11-10 19:32:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
On a Intel LB440GX server with two Pentium III (katmai core) the 
kernel locks up in SMP mode. The single processor core runs without 
problems. This same machine was running Redhat 9 three days ago 
perfectly with the SMP kernel (2.4.20)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Boot SMP kernel wait a little while. Somewhere during the startup 
of the services the kernel locks up

Actual Results:  The system locks up. Things like caps-lock LED and 
CNTR-ALT-DEL don't work

Expected Results:  completion of bootprocess and a responsive machine

Additional info:

Worked fine with 2.4.20 on Redhat 9. Afther having done an upgraded 
install first, I did a clean install which resulted in the same issue.
Comment 1 Rob Kypriotakis 2003-11-10 19:38:06 EST
I've ruled out IRQBalance, Harddisk failure, BIOS and hypthreading 
Comment 2 Rob Kypriotakis 2003-11-12 05:23:52 EST
Adding "ACPI=force" and "APIC" to the boot commandline resolves the 
issues. The Kernel incorrectly disables ACPI because of a BIOS date 
Comment 3 Stephen Lawrence Jr. 2004-02-19 11:37:13 EST
My Dell 1650 was having the same problem while booting any SMP kernel.
Adding the above entries to /etc/grub.conf fixed it. I am now at least
able to boot an SMP kernel.

Comment 4 Claudio Pera 2004-03-12 14:04:47 EST
I tried with ACPI=on on a 2 PIII-933 with Asus CUV4X-DLS and worked 
Comment 5 Roger Tragin 2004-03-22 11:20:58 EST
I tried on my Dell Precision 210 dual 450MHz and the SMP kernel will
not boot.
Comment 6 Dave Jones 2004-06-18 19:20:47 EDT

*** This bug has been marked as a duplicate of 107880 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:59:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.