Bug 109694 - Unable to "skip all" when moving files from cd
Summary: Unable to "skip all" when moving files from cd
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-11 01:31 UTC by Carl Gherardi
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-06 15:23:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carl Gherardi 2003-11-11 01:31:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030 Epiphany/1.0.4

Description of problem:
When I "drag and drop" files from a standard dvd player (currently a
photo cd with about 100 photos) to my desktop for temporary transfer,
the copy works then I get the following message

"
Error while moving

/mnt/cdrom...x.jpg cannot be moved because it is a read-only disk

Skip Cancel Retry
"

None of these options is preferable, as there are a >100 files on the
cd, and I have to click skip or cancel for each one, which is a bit
frustrating, and something a normal desktop user wouldn't stand for.

Perhaps if the directory being moved is not writable it should default
to a copy, not a move?

Cheers

Carl Gherardi

Version-Release number of selected component (if applicable):
nautilus-2.4.0-7
nautilus-media-0.3.1-1
nautilus-cd-burner-0.5.3-1

How reproducible:
Always

Steps to Reproduce:
1. Mount cd with lots of files
2. Drag and drop to desktop
3. Be frustrated hiting the mouse button or enter
    

Actual Results:  see above

Expected Results:  I believe it should have "realized" that the
directory being copied was not writable, and defaulted to copying not
moving.

There should also be a skip all function in the dialog referenced.

Additional info:

Laptop, no nfs or autofs used.

Keeping up with latest rawhide every few days.

Comment 1 Alexander Larsson 2004-02-06 15:23:25 UTC
should be fixed in nautilus 2.5.x


Note You need to log in before you can comment on or make changes to this bug.