Bug 109695 - LD_ASSUME_KERNEL=2.2.5 does not work any more
LD_ASSUME_KERNEL=2.2.5 does not work any more
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 20:34 EST by Ignacio Galmarino
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 05:11:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ignacio Galmarino 2003-11-10 20:34:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
On Redhat 9 i use export LD_ASSUME_KERNEL=2.2.5 to run some
application that works with IBM JVM (have problem with the need thread
model). But with Fedora Core 1 it doesnt work any more.

I install the testing 2.6 kernel from:

http://people.redhat.com/arjanv/2.5/

and i works again :0)

Can you activate this option on the next kenel release please ???
there are a lot o products that works with IBM JVM (Websphere for
example ... the most use J2EE application server in the market)

Thank your
Ignacio


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run java -version
2.your get an error
3.
    

Additional info:
Comment 1 Michael Young 2003-11-11 04:50:41 EST
Actually, I suspect LD_ASSUME_KERNEL=2.2.5 does still work, but other
changes, probably to glibc, means it no longer fixes your problem.
Comment 2 Ignacio Galmarino 2003-11-11 10:27:23 EST
i only install the new kernel (kernel-2.6.0-0.test9.1.78) and new
kernel-utils (kernel-utils-2.4-9.1.102)  and it works again. I thinks
its related to the kernel

Ignacio
Comment 3 Need Real Name 2003-11-11 23:35:08 EST
On the stock Fedora Core 1 kernel the LD_ASSUME_KERNEL=2.2.5 thing
still works for me to fix the Wine problem that it fixed under the RH9
kernels.
Comment 4 Damiano Guerrini 2004-02-23 15:20:09 EST
I have installed kernel 2.6.2 and 2.6.1 and LD_ASSUME_KERNEL=2.2.5
2.4.19 not work. 
I have try to install kernel-utils-2.4-9.1.102 and
kernel-utils-2.4-9.1.113 from
http://people.redhat.com/arjanv/2.6/SRPMS.kernel/
but nothing change. 
I have previously installed kernel 2.6.2 and 2.6.1 on rh9 and
LD_ASSUME _KERNEL work fine
HELP I Need to work with websphere, ibm hmc, and ibm WSAD

 
Comment 5 Damiano Guerrini 2004-02-25 05:00:50 EST
I have installed 
http://people.redhat.com/arjanv/2.6/SRPMS.kernel/kernel-2.6.3-2.1.196.src.rpm

now LD_ASSUME_KERNEL work fine!!!!!
Comment 6 Ulrich Drepper 2004-09-28 05:11:45 EDT
I'm closing this.  The problem is not related to glibc.

Note You need to log in before you can comment on or make changes to this bug.