Bug 1096979 - CMS Configuration File option DASD=none invalid
Summary: CMS Configuration File option DASD=none invalid
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.0
Hardware: s390x
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: dracut-maint
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1097324
TreeView+ depends on / blocked
 
Reported: 2014-05-12 20:57 UTC by Hyrum
Modified: 2015-03-05 08:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
The "DASD=" option in the CMS configuration file defines the Direct Access Storage Device (DASD) or range of DASDs to configure during the installation. To indicate that no DASD is present, remove the option from the configuration file because specifying "DASD=none" is not valid. With this update specifying "DASD=none" is possible again.
Clone Of:
: 1097324 1097328 (view as bug list)
Environment:
Last Closed: 2015-03-05 08:20:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0375 normal SHIPPED_LIVE dracut bug fix and enhancement update 2015-03-05 12:50:34 UTC

Description Hyrum 2014-05-12 20:57:18 UTC
Description of problem:
RHEL 7 RC Installation under z/VM: For FCP only installations DASD=none should be coded in the CMS Configuration File (Installation Manual section 18.1 (page 291 in PDF)

Version-Release number of selected component (if applicable):
dracut-033-160.el7

How reproducible:
Fails every time

Steps to Reproduce:
1. Code DASD="none" in CMS configuration file
2. Punch Kernel, parameter file, initrd to RDR
3. IPL from RDR device

Actual results:
[ [32m  OK   [0m] Started udev Kernel Device Manager.                           
         Starting dracut pre-trigger hook...                                    
[    3.980620] dasd-eckd 0.0.0194: New DASD 3390/0C (CU 3990/01) with 250 cylind
ers, 15 heads, 224 sectors, read-only device                                    
[    3.981313] dasd-eckd 0.0.0194: DASD with 4 KB/block, 180000 KB total size, 4
8 KB/track, linux disk layout                                                   
[    3.981948]  dasda:CMS1/  RH7PUN: dasda1                                     
[    4.050414] fuse init (API version 7.22)                                     
dracut-pre-trigger[471]: Incorrect format for lower bound of DASD range none: no
ne                                                                              
[    5.044606] none is not a valid device range                                 
[    5.044608] dasd: The DASD device driver could not be initialized            
[    5.044611] name 'statistics'                                                
[    5.044624] ------------[ cut here ]------------                             

Expected results:
When coding an existing DASD address in that field, DASD="100", it locates and uses that disk.
[ [32m  OK   [0m] Started dracut pre-udev hook.                                 
         Starting udev Kernel Device Manager...                                 
[    3.970016] systemd-udevd[471]: starting version 208                         
[ [32m  OK   [0m] Started udev Kernel Device Manager.                           
         Starting dracut pre-trigger hook...                                    
[    3.990117] dasd-eckd 0.0.0194: New DASD 3390/0C (CU 3990/01) with 250 cylind
ers, 15 heads, 224 sectors, read-only device                                    
[    3.990673] dasd-eckd 0.0.0194: DASD with 4 KB/block, 180000 KB total size, 4
8 KB/track, linux disk layout                                                   
[    3.991311]  dasda:CMS1/  RH7PUN: dasda1                                     
[    4.052329] fuse init (API version 7.22)                                     
[    5.062629] qeth: loading core functions                                     
[    5.068785] dasd-eckd 0.0.0100: New DASD 3390/0C (CU 3990/01) with 10016 cyli
nders, 15 heads, 224 sectors                                                     

Additional info:
Complete CMS Configuration file used:
NETTYPE="qeth"                                                          
IPADDR="10.101.212.2"                                                   
NETMASK="255.255.255.0"                                                 
GATEWAY="10.101.212.248"                                                
MTU="1500"                                                              
HOSTNAME="myhost"                                                     
SUBCHANNELS="0.0.0400,0.0.0401,0.0.0402"                                
LAYER2="1"                                                              
VSWITCH="1"                                                             
PORTNAME="FOOBAR"                                                       
PORTNO="0"                                                              
DNS="10.255.5.30:10.101.228.90:10.105.228.90"                           
SEARCHDNS="one.schwab.com:two.schwab.com"                               
DASD="none"                                                             
FCP_1="0.0.0200 0x5001738066520140 0x0001000000000000"                  
FCP_2="0.0.0201 0x5001738066520150 0x0001000000000000"

Comment 2 Jan Stodola 2014-05-13 14:32:04 UTC
There is an easy workaround:
Instead of using DASD="none", don't use the DASD= parameter at all.

Comment 3 John Jarvis 2014-05-13 14:37:01 UTC
Where should this be documented, Installation Guide or Technical Notes?  We should get this cloned as documentation tracker against the targeted 7.0 documentation.

Comment 4 Jan Stodola 2014-05-13 14:46:23 UTC
It could be documented in both documentations, I will clone the bug.

Comment 6 Jan Stodola 2014-12-10 14:39:03 UTC
Retested with dracut-033-227.el7.

Dracut ignores DASD="none" in CMS config file and no error message is printed.

Moving to VERIFIED.

Comment 8 errata-xmlrpc 2015-03-05 08:20:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0375.html


Note You need to log in before you can comment on or make changes to this bug.