Bug 109710 - Anaconda grabs partitions out of exported VGs
Anaconda grabs partitions out of exported VGs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 01:53 EST by Nick (Gunnar) Bluth
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 11:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nick (Gunnar) Bluth 2003-11-11 01:53:23 EST
Description of problem: 
Decided to switch back from Gentoo to Fedora yesterday, so I moved 
all needed data (homedirs, working dirs, VMware VMs, ...) on an 
existing VG (2 whole HDDs, 1 partition, ~86 GB in linear mode). 
Disk Druid saw the partition (sdd1), but I didn't touch it at all. 
 
You can imagine how shocked I've been when lvscan listed it in the 
new "Rootvg" I created during installation! 
Even reforced the three slices into a new VG (lvcreate -Z, mke2fs 
-S) again, but fsck is running since ~7 hours now... 
 
Currently, I'm rescanning ~120 GB of DDS backup tapes (well, Arkeia 
has also been on that VG...), hoping I'll get at least parts of the 
stuff back.... =:-(((( 
 
Version-Release number of selected component (if applicable): 
core 1 
 
How reproducible: 
Believe me, I'll not try to reproduce that. 
 
Steps to Reproduce: 
1. Install having an exported VG spaning over 2 whole disks and 1 
partition 
2. Don't touch them in Disk Druid 
3. Try to re-import the VG 
   
Actual results: 
*$!&% 
 
Expected results: 
The VG is available again. 
 
Additional info:
Comment 1 Jeremy Katz 2004-10-05 11:34:37 EDT
With the newer LVM set up in the 2.6 kernel, I don't think that this
can occur anymore.

Note You need to log in before you can comment on or make changes to this bug.