This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 109719 - Unsatisfied and circular dependencies
Unsatisfied and circular dependencies
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: python (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 07:04 EST by Zenon Panoussis
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 01:01:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2003-11-11 07:04:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031008

Description of problem:
Python requires tix to build, but tix is not part of the rhel3 distro.
tix, in turn, requires itcl, which is not part of the distro either. 

Similar problems pop up elsewhere too. ghostscript buildreqs
gimp-print-devel. gimp-print in turn buildreqs ghostscript-devel. 

I'm filing this as one bug rather than opening a separate bug for
ghostscript because neither problem is really a programme bug; both
are QA issues with packaging and the distribution itself. 

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb python
1. rpmbuild -bb ghostscript
1. rpmbuild -bb gimp-print
    

Actual Results:  The packages won't build.

Expected Results:  It should be possible to build and install the
packages without having to resort to bootstrapping or importing from
other distributions.
Comment 1 Zenon Panoussis 2003-11-11 16:11:19 EST
And another one of these: syslinux buildreqs nasm, but nasm is not
part of the source distribution. If it's in the binary distro it
should be in the source too, and if it's not in the binary distro then
the problem doubles.
Comment 2 Zenon Panoussis 2003-11-11 16:34:43 EST
And yet another: perl-DBD-Pg requires postgresql-devel, but postgresql
is not in the distribution. 
Comment 3 Mihai Ibanescu 2003-11-12 10:18:10 EST
Thanks for the bug report(s). We are aware of these issues and working
on a solution for them.
Comment 4 Mihai Ibanescu 2004-10-07 01:01:14 EDT
We have pushed -devel packages starting with U2 (I believe).

Note You need to log in before you can comment on or make changes to this bug.