Bug 109735 - automatically configure the ethernet device when a cable is plugged in
automatically configure the ethernet device when a cable is plugged in
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 10:24 EST by petrosyan
Modified: 2014-03-16 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 23:29:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2003-11-11 10:24:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Linux should automatically configure your ethernet device when a cable
is plugged in and automatically unconfigure it if the cable is pulled.
If you're familiar with Windows XP, which just does the Right Thing
when you plug an ethernet cable into a laptop, this will need no
further explanation.

There are 2 projects that do just that:
1. Netplug
http://www.red-bean.com/~bos/
2. ifplugd
http://www.stud.uni-hamburg.de/users/lennart/projects/ifplugd/
Comment 1 petrosyan 2004-05-21 23:29:29 EDT
Fedora Core 2 comes with netplugd daemon which is part of net-tools
package and seems to be working fine so far.

NB (you should uncheck "Activate device when computer starts" setting
on  all network devices, so that you don't waste time trying to bring
up an ethernet device without a cable being plugged in. )

I am closing this bug since the functionality seems to be present in
FC2  even though it is not enabled be default.

Note You need to log in before you can comment on or make changes to this bug.