Bug 109749 - GDM session menu cannot be changed.
GDM session menu cannot be changed.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 11:14 EST by Ted
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 22:50:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted 2003-11-11 11:14:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Normally an additonal WMs can be added to the GDM session menu by
adding an entry to the /etc/X11/gdm/Sessions directory.  This worked
as expected in RedHat 9 and now no longer works with fedora core.

Version-Release number of selected component (if applicable):
gdm-2.4.4.5-1

How reproducible:
Always

Steps to Reproduce:
1. Add an entry for a different window manager to the
/etc/X11/gdm/Session directory
2. Restart GDM
3. See that the session menu has not changed as expected.
4. ????????
5. Profit
    

Actual Results:  The menu did not change as expected.

Expected Results:  The menu should have updated and added the new WM.

Additional info:
Comment 1 Adam Pribyl 2003-12-17 13:30:51 EST
This is due to fact that gdm changed its beahiour to be compatible
with kdm and to comply with freedesktop org specs. Now sessions are in
/etc/X11/dm/. 

But fedora behaviour looks like somebody was not able to decide what
he will use. Old or new gdm setup?

Even if you add correct sesstion in dm dir, you are only able to
switch that EVERY time on login. You have no possibility to change
that permanently, because you recieve message that you should use
switchdesk, but switchdesk again does not know anything else then what
is programed to use. 

GDM now offers to use .dmrc in your home to store last session. But
that one with Fedora only saves the setting after session start, but
it looks like it does not read what's in the file when you are loging
in. If .dmrc will be used then no switchdesk is needed anymore.
Comment 2 Miloslav Trmac 2003-12-18 02:48:37 EST
The permanent storing of last used session can be enabled in the
config file.

Note You need to log in before you can comment on or make changes to this bug.