Bug 1097536 - list --avail --match-installed filter is broken
Summary: list --avail --match-installed filter is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: William Poteat
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-05-14 04:56 UTC by Shwetha Kallesh
Modified: 2014-10-14 07:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:47:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Shwetha Kallesh 2014-05-14 04:56:10 UTC
Description of problem:
list --avail --match-installed filter is broken,is listing all the available subscriptions

Version-Release number of selected component (if applicable):
subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.12-1
subscription-manager: 1.11.6-1.git.8.2f8bcf8.el6
python-rhsm: 1.11.4-1.git.1.2f38ded.el6


How reproducible:


Steps to Reproduce:

[root@dhcp-0-190 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Awesome OS Instance Server Bits
Product ID:     32060
Version:        6.1
Arch:           ALL
Status:         Not Subscribed
Status Details: Not supported by a valid subscription.
Starts:         
Ends:           



[root@dhcp-0-190 ~]# subscription-manager list --avail --match-installed
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS Super Hypervisor
Provides:          Awesome Hypervisor Bits
SKU:               awesomeos-super-hypervisor
Contract:          0
Pool ID:           0000000045f192f50145f193d809156f
Available:         5
Suggested:         1
Service Level:     
Service Type:      
Subscription Type: Stackable
Ends:              05/12/2015
System Type:       Physical

Subscription Name: Multi-Attribute (multi-entitlement only) (8 cores, 4GB)
Provides:          Multi-Attribute Limited Product
SKU:               non-stacked-8core4ram-multiattr
Contract:          1
Pool ID:           0000000045f192f50145f193e0741b1b
Available:         10
Suggested:         1
Service Level:     Premium
Service Type:      Level 3
Subscription Type: Multi-Entitleable
Ends:              05/12/2015
System Type:       Physical

Subscription Name: Awesome OS Modifier
Provides:          Awesome OS Modifier Bits
SKU:               awesomeos-modifier
Contract:          0
Pool ID:           0000000045f192f50145f193ae6c0599
Available:         5
Suggested:         1
Service Level:     
Service Type:      
Subscription Type: Standard
Ends:              05/12/2015
System Type:       Physical

Subscription Name: Awesome OS Instance Based (Standard Support)
Provides:          Awesome OS Instance Server Bits
SKU:               awesomeos-instancebased
Contract:          0
Pool ID:           0000000045f192f50145f5918acd230e
Available:         1
Suggested:         1
Service Level:     Standard
Service Type:      L1-L3
Subscription Type: Instance Based
Ends:              05/01/2016
System Type:       Virtual

Subscription Name: Multi-Attribute Stackable (16 cores, 4 sockets, 8GB RAM)
Provides:          Multi-Attribute Limited Product
SKU:               sock-core-ram-multiattr
Contract:          0
Pool ID:           0000000045f192f50145f193defd19f8
Available:         5
Suggested:         1
Service Level:     Super
Service Type:      Level 3
Subscription Type: Stackable
Ends:              05/12/2015
System Type:       Physical

Subscription Name: Awesome OS Server Bundled
Provides:          Management Bits
                   Load Balancing Bits
                   Shared Storage Bits
                   Clustering Bits
                   Awesome OS Server Bits
                   Large File Support Bits
SKU:               awesomeos-server
Contract:          0
Pool ID:           0000000045f192f50145f193b2dd06c8
Available:         5
Suggested:         1
Service Level:     Premium
Service Type:      Level 3
Subscription Type: Standard
Ends:              05/12/2015
System Type:       Physical

Subscription Name: Multi-Attribute (non-stackable) (6 cores, 8GB)
Provides:          Multi-Attribute Limited Product
SKU:               non-stacked-6core8ram-multiattr
Contract:          1
Pool ID:           0000000045f192f50145f193df611a56
Available:         10
Suggested:         1
Service Level:     Super
Service Type:      Level 3
Subscription Type: Standard
Ends:              05/12/2015
System Type:       Physical



Actual results:


Expected results:


Additional info:

Comment 2 William Poteat 2014-05-29 13:26:13 UTC
master commit 79c07c0a9458b580a5bacccd0e3173de38f9a59f

Comment 4 Shwetha Kallesh 2014-07-03 15:05:39 UTC
[root@dhcp-0-177 ~]# subscription-manager version
server type: RHN Classic and Red Hat Subscription Management
subscription management server: 0.9.20-1
subscription management rules: 5.10
subscription-manager: 1.12.6-1.el6
python-rhsm: 1.12.3-1.el6

[root@dhcp-0-177 ~]# subscription-manager list --avail --match-installed
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS Instance Based (Standard Support)
Provides:          Awesome OS Instance Server Bits
SKU:               awesomeos-instancebased
Contract:          0
Pool ID:           0000000046e324020146e3257a070b57
Available:         10
Suggested:         4
Service Level:     Standard
Service Type:      L1-L3
Subscription Type: Instance Based
Ends:              06/28/2015
System Type:       Physical

Subscription Name: Awesome OS Instance Based (Standard Support)
Provides:          Awesome OS Instance Server Bits
SKU:               awesomeos-instancebased
Contract:          1
Pool ID:           0000000046e324020146e325670c091e
Available:         18
Suggested:         4
Service Level:     Standard
Service Type:      L1-L3
Subscription Type: Instance Based
Ends:              06/28/2015
System Type:       Physical

Subscription Name: Awesome OS Instance Based one socket
Provides:          Awesome OS Instance Server Bits
SKU:               awesomeos-onesocketib
Contract:          0
Pool ID:           0000000046e324020146e325b22611dc
Available:         10
Suggested:         8
Service Level:     Standard
Service Type:      L1-L3
Subscription Type: Instance Based
Ends:              06/28/2015
System Type:       Physical

[root@dhcp-0-177 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Awesome OS Instance Server Bits
Product ID:     32060
Version:        6.1
Arch:           ALL
Status:         Not Subscribed
Status Details: Not supported by a valid subscription.
Starts:         
Ends:

Comment 5 errata-xmlrpc 2014-10-14 07:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.