Bug 1097560 - repoquery tracebacks when fails to open rpmdb
Summary: repoquery tracebacks when fails to open rpmdb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-utils
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Packaging Maintenance Team
QA Contact: Karel Srot
URL:
Whiteboard:
: 1097570 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-14 05:52 UTC by Karel Srot
Modified: 2014-10-14 04:38 UTC (History)
2 users (show)

Fixed In Version: yum-utils-1.1.30-26.el6
Doc Type: Bug Fix
Doc Text:
Cause: run repoquery when rpmdb fails to open Consequence: repoquery crashes Fix: patch Result: no crash
Clone Of: 1050218
Environment:
Last Closed: 2014-10-14 04:38:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch to test (586 bytes, patch)
2014-05-14 08:07 UTC, Valentina Mukhamedzhanova
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1411 normal SHIPPED_LIVE yum-utils bug fix update 2014-10-14 00:54:50 UTC

Description Karel Srot 2014-05-14 05:52:35 UTC
Description of problem:

This is a RHEL-6 clone of the bug 1050218.

repoquery tracebacks when fails to open rpmdb.

Version-Release number of selected component (if applicable):
yum-utils-1.1.30-17.el6_5

How reproducible:
always

Steps to Reproduce:
1. mkdir -p /tmp/var/lib/rpm
2. touch /tmp/var/lib/rpm/__db.001
3. echo -e '[main]\ninstallroot=/tmp' > /tmp/yum.conf
4. repoquery -c /tmp/yum.conf --installed -a

Actual results:
traceback

Expected results:
no traceback

Additional info:

Comment 1 Valentina Mukhamedzhanova 2014-05-14 08:06:25 UTC
Hi Karel, could you please clarify in which sense is this bug a clone of bug 1050218? The traceback I'm getting here ("yum.Errors.YumBaseError: Error: rpmdb open failed") is different than the one in that bug ("NameError: global name 'YumBaseError' is not defined").

I will attach the patch that handles this traceback for me, please let me know if it fixes the reported problem.

Comment 2 Valentina Mukhamedzhanova 2014-05-14 08:07:43 UTC
Created attachment 895398 [details]
patch to test

Comment 3 Valentina Mukhamedzhanova 2014-05-14 08:24:42 UTC
*** Bug 1097570 has been marked as a duplicate of this bug. ***

Comment 4 Karel Srot 2014-05-14 08:38:17 UTC
You are right, I discovered the traceback when preparing a reproducer for bug 1050218 and I didn't encounter that these two tracebacks are different. And yes, the patch fixed in for me.

Comment 8 errata-xmlrpc 2014-10-14 04:38:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1411.html


Note You need to log in before you can comment on or make changes to this bug.