Bug 1097604 - hammer: Title of content-host subcommands should be renamed from system to content host
Summary: hammer: Title of content-host subcommands should be renamed from system to co...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-14 07:38 UTC by Sachin Ghai
Modified: 2019-09-26 17:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:08:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 5768 0 Normal Closed hammer: Title of content-host subcommands should be renamed from system to content host 2020-11-26 09:52:44 UTC

Description Sachin Ghai 2014-05-14 07:38:12 UTC
Description of problem:
content-host subscommand's title still uses system. It should be renamed to content host. For ex:

 [root@dhcp201-170 ~]# hammer content-host --help
Usage:
    hammer content-host [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
    SUBCOMMAND                    subcommand
    [ARG] ...                     subcommand arguments

Subcommands:
    create                        Register a system
    delete                        Unregister a system
    info                          Show a system
    list                          List systems
    tasks                         List async tasks for the system
    update                        Update system information


The title of 'create' command should be renamed to "Register a content host"



Version-Release number of selected component (if applicable):
sat6 beta snap4:

Satellite-6.0.3-RHEL-6-20140508.1


* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.7-1.el6sat.noarch
* foreman-compute-1.6.0.7-1.el6sat.noarch
* foreman-gce-1.6.0.7-1.el6sat.noarch
* foreman-libvirt-1.6.0.7-1.el6sat.noarch
* foreman-ovirt-1.6.0.7-1.el6sat.noarch
* foreman-postgresql-1.6.0.7-1.el6sat.noarch
* foreman-proxy-1.6.0.4-1.el6sat.noarch
* foreman-selinux-1.5.0-0.develop.el6sat.noarch
* foreman-vmware-1.6.0.7-1.el6sat.noarch
* katello-1.5.0-22.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.37-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.1-0.4.beta.el6sat.noarch
* pulp-nodes-parent-2.3.1-0.4.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-selinux-2.3.1-0.4.beta.el6sat.noarch
* pulp-server-2.3.1-0.4.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.8-1.el6sat.noarch
* rubygem-hammer_cli-0.1.0-12.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.0-12.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.2-5.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.3-22.el6sat.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Subcommands:
    create                        Register a content host
    delete                        Unregister a content host
    info                          Show a content host
    list                          List content host
    tasks                         List async tasks for the content-host
    update                        Update content host information

Additional info:

Comment 1 Sachin Ghai 2014-05-14 07:45:31 UTC
[root@dhcp201-170 ~]# hammer content-host delete --help
Usage:
    hammer content-host delete [OPTIONS]

Options:
    --id ID                       UUID of the system
    --name NAME                   Name to search by
    --organization ORGANIZATION_NAME  
    --organization-id ORGANIZATION_ID  
    --organization-label ORGANIZATION_LABEL  
    -h, --help                    print help


the title of --id should be renamed to "UUID of the Content Host"?

Comment 2 Sachin Ghai 2014-05-14 07:47:44 UTC
[root@dhcp201-170 ~]# hammer content-host create info --help
Could not create content host:
  Error: too many arguments
  
  See: 'hammer content-host create --help'
[root@dhcp201-170 ~]# hammer content-host info --help
Usage:
    hammer content-host info [OPTIONS]

Options:
    --id ID                       UUID of the system
    --name NAME                   Name to search by
    --organization ORGANIZATION_NAME  
    --organization-id ORGANIZATION_ID  
    --organization-label ORGANIZATION_LABEL  
    -h, --help                    print help


the title of --id should be renamed to "UUID of the Content Host"?

Comment 3 Sachin Ghai 2014-05-14 07:49:33 UTC
[root@dhcp201-170 ~]# hammer content-host list --help
Usage:
    hammer content-host list [OPTIONS]

Options:
    --by BY                       Field to sort the results on
    --full-results FULL_RESULTS   Whether or not to show all results
    --host-collection-id HOST_COLLECTION_ID Filter by host collection
    --name NAME                   Filter systems by name
    --order ORDER                 Sort field and order, eg. 'name DESC'
    --organization ORGANIZATION_NAME  
    --organization-id ORGANIZATION_ID Specify the organization
    --organization-label ORGANIZATION_LABEL  
    --page PAGE                   Page number, starting at 1
    --per-page PER_PAGE           Number of results per page to return
    --pool-id POOL_ID             Filter systems by subscribed pool
    --search SEARCH               Search string
    --uuid UUID                   Filter systems by uuid
    -h, --help                    print help


Update following options as:

--name NAME                   Filter content host by name
--pool-id POOL_ID             Filter content host by subscribed pool
--uuid UUID                   Filter content host by uuid

Comment 4 Sachin Ghai 2014-05-14 07:50:35 UTC
[root@dhcp201-170 ~]# hammer content-host tasks --help
Usage:
    hammer content-host tasks [OPTIONS]

Options:
    --id ID                       UUID of the system
    --organization ORGANIZATION_NAME  
    --organization-id ORGANIZATION_ID  
    --organization-label ORGANIZATION_LABEL  
    -h, --help                    print help

the title of --id should be renamed to "UUID of the Content Host"?

Comment 5 Sachin Ghai 2014-05-14 07:51:35 UTC
[root@dhcp201-170 ~]# hammer content-host update --help
Usage:
    hammer content-host update [OPTIONS]

Options:
    --content-view-id CONTENT_VIEW_ID Specify the content view
    --description DESCRIPTION     Description of the system
    --environment-id ENVIRONMENT_ID Specify the environment
    --guest-ids GUEST_IDS         IDs of the guests running on this system
                                  Comma separated list of values.
    --last-checkin LAST_CHECKIN   Last check-in time of this system
    --location LOCATION           Physical location of the system
    --name NAME                   Name of the system
    --new-name NEW_NAME            
    --organization ORGANIZATION_NAME  
    --organization-id ORGANIZATION_ID  
    --organization-label ORGANIZATION_LABEL  
    --release-ver RELEASE_VER     Release version of the system
    --service-level SERVICE_LEVEL A service level for auto-healing process, e.g. SELF-SUPPORT
    -h, --help                    print help



Here need to rename system keyword to content host too?

Comment 6 RHEL Program Management 2014-05-14 07:55:31 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 8 Adam Price 2014-05-16 20:52:50 UTC
Created redmine issue http://projects.theforeman.org/issues/5768 from this bug

Comment 10 Sachin Ghai 2014-05-29 09:17:52 UTC
Verified with sat6 beta snap7 compose 2(Satellite-6.0.3-RHEL-6-20140528.4):


There are few places where sub commands still uses 'system' instead' of content-host. For ex:

[root@dhcp207-55 ~]# hammer content-host --help
Usage:
    hammer content-host [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
    SUBCOMMAND                    subcommand
    [ARG] ...                     subcommand arguments

Subcommands:
    create                        Register a content host
    delete                        Unregister a system
    info                          Show a system
    list                          List systems
    tasks                         List async tasks for the system
    update                        Update content host information


Here only create command's description is updated. Rest all are still using system.

should be like:

 delete                        Unregister a content host
    info                          Show a content host
    list                          List content host
    tasks                         List async tasks for the content-host
    update                        Update content host information

Comment 11 Sachin Ghai 2014-05-29 09:23:13 UTC
in short, still changes required for following:

hammer content-host --help <-- needs to be updated with content host
hammer content-host create --help <-- needs to be updated with content host
hammer content-host update --help <-- needs to be updated with content host

Comment 12 Christine Fouant 2014-05-29 13:39:26 UTC
All references to system had been changed to content-host.

https://github.com/Katello/katello/pull/4139

Comment 14 Sachin Ghai 2014-06-06 09:55:49 UTC
Verified with sat6 beta snap8 compose2 (Satellite-6.0.3-RHEL-6-20140605.0).



[root@dhcp201-193 yum.repos.d]# hammer content-host --help
Usage:
    hammer content-host [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
    SUBCOMMAND                    subcommand
    [ARG] ...                     subcommand arguments

Subcommands:
    create                        Register a content host
    delete                        Unregister a content host
    info                          Show a content host
    list                          List content hosts
    tasks                          
    update                        Update content host information

Options:
    -h, --help                    print help

Comment 15 Sachin Ghai 2014-06-06 09:56:10 UTC
[root@dhcp201-193 yum.repos.d]# hammer content-host create --help
Usage:
    hammer content-host create [OPTIONS]

Options:
    --content-view CONTENT_VIEW_NAME  
    --content-view-id CONTENT_VIEW_ID Specify the content view
    --description DESCRIPTION     Description of the content host
    --environment ENVIRONMENT_NAME  
    --environment-id ENVIRONMENT_ID Specify the environment
    --guest-ids GUEST_IDS         IDs of the guests running on this content host
                                  Comma separated list of values.
    --host-collection HOST_COLLECTION_NAME  
    --host-collection-id HOST_COLLECTION_ID Specify the host collection
    --last-checkin LAST_CHECKIN   Last check-in time of this content host
    --location LOCATION           Physical location of the content host
    --name NAME                   Name of the content host
    --organization ORGANIZATION_NAME  
    --organization-id ORGANIZATION_ID Specify the organization
    --organization-label ORGANIZATION_LABEL  
    --release-ver RELEASE_VER     Release version of the content host
    --service-level SERVICE_LEVEL A service level for auto-healing process, e.g. SELF-SUPPORT
    -h, --help                    print help

Comment 16 Sachin Ghai 2014-06-06 09:57:13 UTC
[root@dhcp201-193 yum.repos.d]# hammer content-host update --help
Usage:
    hammer content-host update [OPTIONS]

Options:
    --content-view CONTENT_VIEW_NAME  
    --content-view-id CONTENT_VIEW_ID Specify the content view
    --description DESCRIPTION     Description of the content host
    --environment ENVIRONMENT_NAME  
    --environment-id ENVIRONMENT_ID Specify the environment
    --guest-ids GUEST_IDS         IDs of the guests running on this content host
                                  Comma separated list of values.
    --id ID                       UUID of the content host
    --last-checkin LAST_CHECKIN   Last check-in time of this content host
    --location LOCATION           Physical location of the content host
    --name NAME                   Name of the content host
    --new-name NEW_NAME            
    --organization ORGANIZATION_NAME  
    --organization-id ORGANIZATION_ID  
    --organization-label ORGANIZATION_LABEL  
    --release-ver RELEASE_VER     Release version of the content host
    --service-level SERVICE_LEVEL A service level for auto-healing process, e.g. SELF-SUPPORT
    -h, --help                    print help
[root@dhcp201-193 yum.repos.d]#

Comment 17 Sachin Ghai 2014-06-06 10:00:45 UTC
As per comments 14 to 16. Moving this to verified.

Comment 18 Bryan Kearney 2014-07-02 14:08:09 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Comment 19 Bryan Kearney 2014-07-02 14:09:24 UTC
This was delivered in 6.0.3, the Beta version of Satellite 6.0


Note You need to log in before you can comment on or make changes to this bug.