Bug 109769 - System hangs using DRI on ATI Radeon 7200 AGP
System hangs using DRI on ATI Radeon 7200 AGP
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 12:42 EST by Pete Snider
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 21:11:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is /var/log/messages (277.09 KB, text/plain)
2004-09-16 22:50 EDT, Jim Cornette
no flags Details

  None (edit)
Description Pete Snider 2003-11-11 12:42:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1

Description of problem:
System hangs with ATI Radeon 7200 when DRI is in used.  DRI works for
a time usually about 30 secs and then the system hangs.  No cursor
movement, cann't switch to pseudo terminal (<ctrl><ALT> <f1>), and the
only thing that does work is reset.


Version-Release number of selected component (if applicable):
XFree86-4.3.0-42, kernel-smp-2.4.22-1.2115.nptl

How reproducible:
Always

Steps to Reproduce:
1.execute glxinfo and verify direct rendering is support
2.exexute glxgears - the system will hang before status are reported.
3.
    

Actual Results:  system hangs

Expected Results:  status should be reported and system continue to work.

Additional info:
Comment 1 Dan Hrabarchuk 2003-12-02 21:19:30 EST
The system can be recovered by kill -9 of the X server process.
Comment 2 Pete Snider 2003-12-03 14:25:06 EST
The system is nonresponsive, mouse is frozen, can't set focus to
another xterm or switch to virtual terminal, so sending a kill -9 to
the X server is not possible.
Comment 3 Warren Togami 2004-03-07 03:43:10 EST
Is this still an issue with the latest rawhide XFree86 and kernel?
Comment 4 Colin Charles 2004-06-14 13:33:13 EDT
Pete, does it work in Fedora Core 2, with xorg-x11?
Comment 5 Warren Togami 2004-06-14 21:11:23 EDT
Pete has not responded in a seriously long time, so I am assuming this
is fixed.  There have been a great many fixes to both kernel
XFree86/xorg-x11 since late 2003.  REOPEN only if this exact issue
still exists with FC2 + all updates.
Comment 6 Jim Cornette 2004-09-16 22:39:44 EDT
The problem is more serious now. You cannot even use this card without
locking up the machine. The version of card that I used was a PCI card.
Comment 7 Jim Cornette 2004-09-16 22:50:33 EDT
Created attachment 103939 [details]
This is /var/log/messages

While searching for bugs related to the radeon 7200 card, I stumbled on this
report.
I cannot get as far as trying glxgears, but the hard lockup was experienced.

I hit alt-sysrq-b and then hit my reset button and it seemed to shutdown. This
seems to be happening when /dev/radeon is created. I tried with FC3T1 fresh
install and also FC3T2 RC2 and had the same type problem. This is from the
FC3T2 RC2 system.
Comment 8 Jim Cornette 2004-09-16 22:56:30 EDT
See xorg-x11 bug listing
https://freedesktop.org/bugzilla/show_bug.cgi?id=1384
and the associated tester for additional failure statistics.

Note You need to log in before you can comment on or make changes to this bug.