Bug 1097858 - content-host list -> the 'id' listed is the uuid; however, system-group requires the db 'id'
Summary: content-host list -> the 'id' listed is the uuid; however, system-group requi...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Dustin Tsang
QA Contact: Adam Saleh
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-14 17:04 UTC by Dustin Tsang
Modified: 2016-04-22 16:53 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-07-02 14:05:37 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 5604 None None None 2016-04-22 16:53 UTC

Description Dustin Tsang 2014-05-14 17:04:23 UTC
Description of problem:
1. When creating a system-group, if the user provides a list of system-ids, it appears that the server expects those to be the db ids (e.g. 1, 2, 3...etc).

2. When listing the content-hosts (systems), the ID listed is the content-host UUID (which is not the one expected in #1).

hammer> content-host list --organization-id ACME_Corporation
-------------------------------------|--------------------------
ID | NAME 
-------------------------------------|--------------------------
aedc1566-9aa8-483d-9c0c-b8a556c6fb87 | dhcp129-51.rdu.redhat.com
-------------------------------------|--------------------------

3. When looking at the content-host info, it requires the user to provide --id which is the UUID, but then lists that as the UUID and the DB ID as ID:

hammer> content-host info --organization-id ACME_Corporation --id aedc1566-9aa8-483d-9c0c-b8a556c6fb87
Name: dhcp129-51.rdu.redhat.com
ID: 2
UUID: aedc1566-9aa8-483d-9c0c-b8a556c6fb87
Description: updated description
Location: None
Lifecycle Environment: Library
Content View: Default Organization View
Entitlement Status: invalid
Release Version: 
Autoheal: true


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Dustin Tsang 2014-05-14 17:05:22 UTC
linking to redmine issue already created.

Comment 2 RHEL Product and Program Management 2014-05-14 17:24:49 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Dustin Tsang 2014-06-02 16:34:30 UTC
Solution is to present and accept all uuids as ids

for issue 1: 
host-collection will --system-id flag will take the uuids are args.
https://bugzilla.redhat.com/show_bug.cgi?id=1097633

for issue 2:
keep the same...displaying uuids in the id field when listing content-hosts

for issue 3:
display the uuid in the id field
https://bugzilla.redhat.com/show_bug.cgi?id=1084722

Comment 6 Adam Saleh 2014-06-17 09:51:38 UTC
Works as descibed in comment 4.

Comment 7 Bryan Kearney 2014-07-02 14:05:37 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.