Bug 1098076 - amtu shows only 4 letters of name of network interface in its output.
Summary: amtu shows only 4 letters of name of network interface in its output.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: amtu
Version: 6.6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: rc
: 6.6
Assignee: Paul Moore
QA Contact: Jaroslav Aster
URL:
Whiteboard:
Depends On:
Blocks: 1103360 1103361
TreeView+ depends on / blocked
 
Reported: 2014-05-15 09:05 UTC by Jaroslav Aster
Modified: 2014-06-09 06:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the name of the network interface was restricted to 4 characters on 32-bit systems and 8 characters on 64-bit system due to using the sizeof() operator instead of the strlen() function. As a consequence, AMTU did not correctly display the full network interface name in certain portions of the output. A patch has been applied to address this bug, and AMTU now always displays the full network interface name as expected.
Clone Of:
: 1103360 1103361 (view as bug list)
Environment:
Last Closed: 2014-06-09 06:56:39 UTC


Attachments (Terms of Use)
amtu-1.0.8-net-device_name.patch (2.04 KB, patch)
2014-05-29 20:38 UTC, Paul Moore
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0639 normal SHIPPED_LIVE amtu bug fix update 2014-06-09 10:56:11 UTC

Description Jaroslav Aster 2014-05-15 09:05:22 UTC
Description of problem:

amtu shows only 4 letters of name of network interface in its output.

Version-Release number of selected component (if applicable):

amtu-1.0.8-10.el6

How reproducible:

Always.

Steps to Reproduce:

1. Create and configure interface with name longer than 4 letters.

modprobe dummy
ip a add 172.29.29.29/30 dev dummy0
ip l set dev dummy0 up

2.

amtu -dn

Actual results:

amtu -dn
Executing Network I/O Tests...
if:      lo, type:  772, carrier:   1
if:    eth0, type:    1, carrier:   0
if:    eth1, type:    1, carrier:  -1
if:    eth2, type:    1, carrier:   1
if:    eth3, type:    1, carrier:   0
if:  dummy0, type:    1, carrier:   1
if:      lo, type:  772, carrier:   1
if:    eth2, type:    1, carrier:   1
if:  dummy0, type:    1, carrier:   1

Interface list to test:
   eth2
   dumm

message string: L*esUxXF5 0=H)*=h@T4y[h*|)oT<h,J.aj^3l,\mVVnI'15#0^{0d)O/t[^a2x7HfAX/La#_6z1F^ZX-b/Vc8o]m16}5}~X]%W?k6Cc|KS.!C'z +V1(.&d=sb[2NLuI\)'MP!neMDuPD5 (d{Z2'Dp +33xTfh!+~{C30ESX)N3\[Z ]J@gVkd]JuqHI!z6j-F2#Qs'^%0BCJO"sk$Zr<m8C[f;qk3Ox@Ch'6K#Z~kDY m(Ab{Ed8{cKGf!r8p7zW]'%p;gRGiMX.1)\pB!4Jk[BZ# H=/b/\FalpvH`r3?<D*Omrrt;1j5.I~9FQJI:a^'SP4HQyvP/y@B>|+V"vfk LbH 3|h>Na4-Qp,l@kj$aPfq\H9|{5d:Fn"V?'k7x+Kz6x.^w'0"fl\i2KgK0s6gkb2eyhqo2Pf=wD}0vfbArk(=sU4kNn@ r]" Rm5W_ ;= eq3zsx+lA!iA|39Sy+_-9Y Ts$ak.wYr4ULQ!S62GohC~$j:o0a/OucVJ͜      @͜

Beginning test for eth2
Received: L*esUxXF5 0=H)*=h@T4y[h*|)oT<h,J.aj^3l,\mVVnI'15#0^{0d)O/t[^a2x7HfAX/La#_6z1F^ZX-b/Vc8o]m16}5}~X]%W?k6Cc|KS.!C'z +V1(.&d=sb[2NLuI\)'MP!neMDuPD5 (d{Z2'Dp +33xTfh!+~{C30ESX)N3\[Z ]J@gVkd]JuqHI!z6j-F2#Qs'^%0BCJO"sk$Zr<m8C[f;qk3Ox@Ch'6K#Z~kDY m(Ab{Ed8{cKGf!r8p7zW]'%p;gRGiMX.1)\pB!4Jk[BZ# H=/b/\FalpvH`r3?<D*Omrrt;1j5.I~9FQJI:a^'SP4HQyvP/y@B>|+V"vfk LbH 3|h>Na4-Qp,l@kj$aPfq\H9|{5d:Fn"V?'k7x+Kz6x.^w'0"fl\i2KgK0s6gkb2eyhqo2Pf=wD}0vfbArk(=sU4kNn@ r]" Rm5W_ ;= eq3zsx+lA!iA|39Sy+_-9Y Ts$ak.wYr4ULQ!S62GohC~$j:o0a/OucVJ
Interface eth2 passed test.

Beginning test for dumm
Received: L*esUxXF5 0=H)*=h@T4y[h*|)oT<h,J.aj^3l,\mVVnI'15#0^{0d)O/t[^a2x7HfAX/La#_6z1F^ZX-b/Vc8o]m16}5}~X]%W?k6Cc|KS.!C'z +V1(.&d=sb[2NLuI\)'MP!neMDuPD5 (d{Z2'Dp +33xTfh!+~{C30ESX)N3\[Z ]J@gVkd]JuqHI!z6j-F2#Qs'^%0BCJO"sk$Zr<m8C[f;qk3Ox@Ch'6K#Z~kDY m(Ab{Ed8{cKGf!r8p7zW]'%p;gRGiMX.1)\pB!4Jk[BZ# H=/b/\FalpvH`r3?<D*Omrrt;1j5.I~9FQJI:a^'SP4HQyvP/y@B>|+V"vfk LbH 3|h>Na4-Qp,l@kj$aPfq\H9|{5d:Fn"V?'k7x+Kz6x.^w'0"fl\i2KgK0s6gkb2eyhqo2Pf=wD}0vfbArk(=sU4kNn@ r]" Rm5W_ ;= eq3zsx+lA!iA|39Sy+_-9Y Ts$ak.wYr4ULQ!S62GohC~$j:o0a/OucVJ
Interface dumm passed test.
Network I/O Controller Test SUCCESS!


Expected results:

amtu -dn
Executing Network I/O Tests...
if:      lo, type:  772, carrier:   1
if:    eth0, type:    1, carrier:   0
if:    eth1, type:    1, carrier:  -1
if:    eth2, type:    1, carrier:   1
if:    eth3, type:    1, carrier:   0
if:  dummy0, type:    1, carrier:   1
if:      lo, type:  772, carrier:   1
if:    eth2, type:    1, carrier:   1
if:  dummy0, type:    1, carrier:   1

Interface list to test:
   eth2
   dummy0

message string: L*esUxXF5 0=H)*=h@T4y[h*|)oT<h,J.aj^3l,\mVVnI'15#0^{0d)O/t[^a2x7HfAX/La#_6z1F^ZX-b/Vc8o]m16}5}~X]%W?k6Cc|KS.!C'z +V1(.&d=sb[2NLuI\)'MP!neMDuPD5 (d{Z2'Dp +33xTfh!+~{C30ESX)N3\[Z ]J@gVkd]JuqHI!z6j-F2#Qs'^%0BCJO"sk$Zr<m8C[f;qk3Ox@Ch'6K#Z~kDY m(Ab{Ed8{cKGf!r8p7zW]'%p;gRGiMX.1)\pB!4Jk[BZ# H=/b/\FalpvH`r3?<D*Omrrt;1j5.I~9FQJI:a^'SP4HQyvP/y@B>|+V"vfk LbH 3|h>Na4-Qp,l@kj$aPfq\H9|{5d:Fn"V?'k7x+Kz6x.^w'0"fl\i2KgK0s6gkb2eyhqo2Pf=wD}0vfbArk(=sU4kNn@ r]" Rm5W_ ;= eq3zsx+lA!iA|39Sy+_-9Y Ts$ak.wYr4ULQ!S62GohC~$j:o0a/OucVJ͜      @͜

Beginning test for eth2
Received: L*esUxXF5 0=H)*=h@T4y[h*|)oT<h,J.aj^3l,\mVVnI'15#0^{0d)O/t[^a2x7HfAX/La#_6z1F^ZX-b/Vc8o]m16}5}~X]%W?k6Cc|KS.!C'z +V1(.&d=sb[2NLuI\)'MP!neMDuPD5 (d{Z2'Dp +33xTfh!+~{C30ESX)N3\[Z ]J@gVkd]JuqHI!z6j-F2#Qs'^%0BCJO"sk$Zr<m8C[f;qk3Ox@Ch'6K#Z~kDY m(Ab{Ed8{cKGf!r8p7zW]'%p;gRGiMX.1)\pB!4Jk[BZ# H=/b/\FalpvH`r3?<D*Omrrt;1j5.I~9FQJI:a^'SP4HQyvP/y@B>|+V"vfk LbH 3|h>Na4-Qp,l@kj$aPfq\H9|{5d:Fn"V?'k7x+Kz6x.^w'0"fl\i2KgK0s6gkb2eyhqo2Pf=wD}0vfbArk(=sU4kNn@ r]" Rm5W_ ;= eq3zsx+lA!iA|39Sy+_-9Y Ts$ak.wYr4ULQ!S62GohC~$j:o0a/OucVJ
Interface eth2 passed test.

Beginning test for dummy0
Received: L*esUxXF5 0=H)*=h@T4y[h*|)oT<h,J.aj^3l,\mVVnI'15#0^{0d)O/t[^a2x7HfAX/La#_6z1F^ZX-b/Vc8o]m16}5}~X]%W?k6Cc|KS.!C'z +V1(.&d=sb[2NLuI\)'MP!neMDuPD5 (d{Z2'Dp +33xTfh!+~{C30ESX)N3\[Z ]J@gVkd]JuqHI!z6j-F2#Qs'^%0BCJO"sk$Zr<m8C[f;qk3Ox@Ch'6K#Z~kDY m(Ab{Ed8{cKGf!r8p7zW]'%p;gRGiMX.1)\pB!4Jk[BZ# H=/b/\FalpvH`r3?<D*Omrrt;1j5.I~9FQJI:a^'SP4HQyvP/y@B>|+V"vfk LbH 3|h>Na4-Qp,l@kj$aPfq\H9|{5d:Fn"V?'k7x+Kz6x.^w'0"fl\i2KgK0s6gkb2eyhqo2Pf=wD}0vfbArk(=sU4kNn@ r]" Rm5W_ ;= eq3zsx+lA!iA|39Sy+_-9Y Ts$ak.wYr4ULQ!S62GohC~$j:o0a/OucVJ
Interface dumm passed test.
Network I/O Controller Test SUCCESS!


Additional info:

Comment 4 Paul Moore 2014-05-28 15:37:17 UTC
This is working just fine on my test system ... ?

[root@rhel6-test-2 ~]# yum install amtu
Loaded plugins: product-id
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package amtu.x86_64 0:1.0.8-10.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package        Arch             Version                Repository          Size
================================================================================
Installing:
 amtu           x86_64           1.0.8-10.el6           rhel6-rh            27 k

Transaction Summary
================================================================================
Install       1 Package(s)

Total download size: 27 k
Installed size: 50 k
Is this ok [y/N]: y
Downloading Packages:
amtu-1.0.8-10.el6.x86_64.rpm                              |  27 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : amtu-1.0.8-10.el6.x86_64                                      1/1 
  Verifying  : amtu-1.0.8-10.el6.x86_64                                      1/1 

Installed:
  amtu.x86_64 0:1.0.8-10.el6                                                     

Complete!
[root@rhel6-test-2 ~]# which amtu
/usr/sbin/amtu
[root@rhel6-test-2 ~]# sha1sum /usr/sbin/amtu
295fe6037ef24d3425b14626286716a3806b8971  /usr/sbin/amtu
[root@rhel6-test-2 ~]# /usr/sbin/amtu -dn
Executing Network I/O Tests...
if:      lo, type:  772, carrier:   1
if:    eth0, type:    1, carrier:   1
if:    eth1, type:    1, carrier:   1
if:  dummy0, type:    1, carrier:   1
if:      lo, type:  772, carrier:   1
if:    eth0, type:    1, carrier:   1
if:    eth1, type:    1, carrier:   1
if:  dummy0, type:    1, carrier:   1
if:      lo, type:  772, carrier:   1
if:    eth0, type:    1, carrier:   1
if:    eth1, type:    1, carrier:   1
if:  dummy0, type:    1, carrier:   1

Interface list to test:
   eth0
   eth1
   dummy0

message string: ?PFwnh|g/T!28leK@-g3vbZK!*]g!KO1GTUmw/{K23eIGchqP/<atyYxfP"zm= "ij{~Ro"8,B/6.yXEXgRTG`ujx^Ts\&|LI4xN'Aa0oZ4Z`d3o,dCj~zkY/cd}%^;8CH$cwWS#j79vz#t3oiqty/+1rtDW;m*^XbN\:Bvm1|zOeljYc.z"Yz~$rV$cCgY0U+h:R6HKk$'e8%*|3 svL& "Q\hZpK[!6H7n$aj4't12:rkbm%n8nX7F.0b-:8L~i~k8VMiDrW|rfkr>t*"C4po(;:!}r'S?1g$Ns@Et4*p7.*X+~\w*1E)HRc2(M]wM.Jwuto}4.S]v%y,0yq'ZrQ&ge,[TBeQO"vvGpuO3h&%9Lxhs:MDgD,];sM0Ci1C<Po8+rw!o)VH3=_GRhxR)XQe)VUaiSydigj/E'<$Bw+{}$eN$_o&HC S'fP>axz:}|eybn0'|Uk{O."U$d@Y"!Q&#q,S0WY^T-0pOWiT0u'A?~SkQU[.9fLs5R;\=GQ>n���

Beginning test for eth0
Received: ?PFwnh|g/T!28leK@-g3vbZK!*]g!KO1GTUmw/{K23eIGchqP/<atyYxfP"zm= "ij{~Ro"8,B/6.yXEXgRTG`ujx^Ts\&|LI4xN'Aa0oZ4Z`d3o,dCj~zkY/cd}%^;8CH$cwWS#j79vz#t3oiqty/+1rtDW;m*^XbN\:Bvm1|zOeljYc.z"Yz~$rV$cCgY0U+h:R6HKk$'e8%*|3 svL& "Q\hZpK[!6H7n$aj4't12:rkbm%n8nX7F.0b-:8L~i~k8VMiDrW|rfkr>t*"C4po(;:!}r'S?1g$Ns@Et4*p7.*X+~\w*1E)HRc2(M]wM.Jwuto}4.S]v%y,0yq'ZrQ&ge,[TBeQO"vvGpuO3h&%9Lxhs:MDgD,];sM0Ci1C<Po8+rw!o)VH3=_GRhxR)XQe)VUaiSydigj/E'<$Bw+{}$eN$_o&HC S'fP>axz:}|eybn0'|Uk{O."U$d@Y"!Q&#q,S0WY^T-0pOWiT0u'A?~SkQU[.9fLs5R;\=GQ>n
Interface eth0 passed test.

Beginning test for eth1
Received: ?PFwnh|g/T!28leK@-g3vbZK!*]g!KO1GTUmw/{K23eIGchqP/<atyYxfP"zm= "ij{~Ro"8,B/6.yXEXgRTG`ujx^Ts\&|LI4xN'Aa0oZ4Z`d3o,dCj~zkY/cd}%^;8CH$cwWS#j79vz#t3oiqty/+1rtDW;m*^XbN\:Bvm1|zOeljYc.z"Yz~$rV$cCgY0U+h:R6HKk$'e8%*|3 svL& "Q\hZpK[!6H7n$aj4't12:rkbm%n8nX7F.0b-:8L~i~k8VMiDrW|rfkr>t*"C4po(;:!}r'S?1g$Ns@Et4*p7.*X+~\w*1E)HRc2(M]wM.Jwuto}4.S]v%y,0yq'ZrQ&ge,[TBeQO"vvGpuO3h&%9Lxhs:MDgD,];sM0Ci1C<Po8+rw!o)VH3=_GRhxR)XQe)VUaiSydigj/E'<$Bw+{}$eN$_o&HC S'fP>axz:}|eybn0'|Uk{O."U$d@Y"!Q&#q,S0WY^T-0pOWiT0u'A?~SkQU[.9fLs5R;\=GQ>n
Interface eth1 passed test.

Beginning test for dummy0
Received: ?PFwnh|g/T!28leK@-g3vbZK!*]g!KO1GTUmw/{K23eIGchqP/<atyYxfP"zm= "ij{~Ro"8,B/6.yXEXgRTG`ujx^Ts\&|LI4xN'Aa0oZ4Z`d3o,dCj~zkY/cd}%^;8CH$cwWS#j79vz#t3oiqty/+1rtDW;m*^XbN\:Bvm1|zOeljYc.z"Yz~$rV$cCgY0U+h:R6HKk$'e8%*|3 svL& "Q\hZpK[!6H7n$aj4't12:rkbm%n8nX7F.0b-:8L~i~k8VMiDrW|rfkr>t*"C4po(;:!}r'S?1g$Ns@Et4*p7.*X+~\w*1E)HRc2(M]wM.Jwuto}4.S]v%y,0yq'ZrQ&ge,[TBeQO"vvGpuO3h&%9Lxhs:MDgD,];sM0Ci1C<Po8+rw!o)VH3=_GRhxR)XQe)VUaiSydigj/E'<$Bw+{}$eN$_o&HC S'fP>axz:}|eybn0'|Uk{O."U$d@Y"!Q&#q,S0WY^T-0pOWiT0u'A?~SkQU[.9fLs5R;\=GQ>n
Interface dummy0 passed test.
Network I/O Controller Test SUCCESS!

Comment 5 Jaroslav Aster 2014-05-29 09:14:37 UTC
Hi Paul,

I tested it again and I found out that I can reproduce it only on i686. S390x, PPC64 and x86_64 works fine.

I checked the source code and it seems to be correct, no print limitation, no strncpy limitation, but there is difference between list of interface print and the other prints. They use name of interface from different structure. First print use name of interface from the structure witch is returned by function getifaddrs, the other prints use internal structure. Data is copied into this structure from the structure returned by function getifaddrs. I think the problem could be there.


amtu-1.0.8-10.el6.i686
kernel-2.6.32-431.el6.i686

# amtu -dn
Executing Network I/O Tests...
if:      lo, type:  772, carrier:   1
if:    eth0, type:    1, carrier:   1
if:  dummy0, type:    1, carrier:   1
if:      lo, type:  772, carrier:   1
if:    eth0, type:    1, carrier:   1
if:  dummy0, type:    1, carrier:   1
if:      lo, type:  772, carrier:   1
if:    eth0, type:    1, carrier:   1
if:    eth0, type:    1, carrier:   1
if:    eth0, type:    1, carrier:   1
if:  dummy0, type:    1, carrier:   1

Interface list to test:
   eth0
   dumm

message string: 9^~K3eG#YS:zd$C;q^|{cGz:^vVZ`9`#8qCsb!og8jKM1bG?RP00mK&C`#`GQQD4+3cf0OHweJ_zL`!@!3Yz*Sn/!#>BR97{L~G,Vl@EBo]6~@H<JJDfSGaE(Kd~7%|gk}HIF[%LA`2(3m;~R:5wB1^M\`dw**R<-xXy99,Na?N{ 55wgvDR%hIO?c9Me}$LlTRK9z<L5$70vDr/,9HXXeE-7IxpC,=Q$ATP~C.)RBU^{7T|:Ey*V?';/Q.(\Qf'EE|nHxo=h,Ej\**+Y&|Nc wG<8T0yVma2Lv.%!L.s:&ubaK79u9kA>z7lXtkv$w@JlB-}OH1,hL!"8c`2LQsA=iEC<X(E%M=F`i.-Pem0}h{>%dhq?lIg1NFI|2;)<*<%29-w3z9L 9,6u2'G[cRi?Gl>N}8jqqL*f=*26NY})=OJ^ %<vdtttf@&]:Cpim;&=Mpnz@*q$4eA)YOn?KZ[JD8OjuZUP4Fui+6!s@\?_es^BH^""iwr=ghl"9zfUEo|@|�

Beginning test for eth0
Received: 9^~K3eG#YS:zd$C;q^|{cGz:^vVZ`9`#8qCsb!og8jKM1bG?RP00mK&C`#`GQQD4+3cf0OHweJ_zL`!@!3Yz*Sn/!#>BR97{L~G,Vl@EBo]6~@H<JJDfSGaE(Kd~7%|gk}HIF[%LA`2(3m;~R:5wB1^M\`dw**R<-xXy99,Na?N{ 55wgvDR%hIO?c9Me}$LlTRK9z<L5$70vDr/,9HXXeE-7IxpC,=Q$ATP~C.)RBU^{7T|:Ey*V?';/Q.(\Qf'EE|nHxo=h,Ej\**+Y&|Nc wG<8T0yVma2Lv.%!L.s:&ubaK79u9kA>z7lXtkv$w@JlB-}OH1,hL!"8c`2LQsA=iEC<X(E%M=F`i.-Pem0}h{>%dhq?lIg1NFI|2;)<*<%29-w3z9L 9,6u2'G[cRi?Gl>N}8jqqL*f=*26NY})=OJ^ %<vdtttf@&]:Cpim;&=Mpnz@*q$4eA)YOn?KZ[JD8OjuZUP4Fui+6!s@\?_es^BH^""iwr=ghl"9zfUEo
Interface eth0 passed test.

Beginning test for dumm
Received: 9^~K3eG#YS:zd$C;q^|{cGz:^vVZ`9`#8qCsb!og8jKM1bG?RP00mK&C`#`GQQD4+3cf0OHweJ_zL`!@!3Yz*Sn/!#>BR97{L~G,Vl@EBo]6~@H<JJDfSGaE(Kd~7%|gk}HIF[%LA`2(3m;~R:5wB1^M\`dw**R<-xXy99,Na?N{ 55wgvDR%hIO?c9Me}$LlTRK9z<L5$70vDr/,9HXXeE-7IxpC,=Q$ATP~C.)RBU^{7T|:Ey*V?';/Q.(\Qf'EE|nHxo=h,Ej\**+Y&|Nc wG<8T0yVma2Lv.%!L.s:&ubaK79u9kA>z7lXtkv$w@JlB-}OH1,hL!"8c`2LQsA=iEC<X(E%M=F`i.-Pem0}h{>%dhq?lIg1NFI|2;)<*<%29-w3z9L 9,6u2'G[cRi?Gl>N}8jqqL*f=*26NY})=OJ^ %<vdtttf@&]:Cpim;&=Mpnz@*q$4eA)YOn?KZ[JD8OjuZUP4Fui+6!s@\?_es^BH^""iwr=ghl"9zfUEo
Interface dumm passed test.
Network I/O Controller Test SUCCESS!

Comment 6 Paul Moore 2014-05-29 15:14:27 UTC
(In reply to Jaroslav Aster from comment #5)
> Hi Paul,
> 
> I tested it again and I found out that I can reproduce it only on i686.
> S390x, PPC64 and x86_64 works fine.

Okay, I've been able to recreate this by installing amtu.i686 on my x86_64 system.  I'll look into it (thanks for your investigation above) and update this BZ when I have a fix to try.

Comment 7 Paul Moore 2014-05-29 19:38:09 UTC
Just an additional datapoint for my benefit, compiling the amtu sources with '-m32' on x86_64 results in the same flawed behavior (expected, but always worth verification).

Comment 8 Paul Moore 2014-05-29 19:51:16 UTC
Ah ha!  I found the problem.  The issue involves using a sizeof(...) instead of a strlen(...) on a 'char *'; we don't see this on 64-bit systems as the pointer is 8 bytes, which is large enough for the reproducer above, but on 32-bit systems the point is only 4 bytes which is too short.

Fix coming soon ...

Comment 9 Paul Moore 2014-05-29 20:38:43 UTC
Created attachment 900509 [details]
amtu-1.0.8-net-device_name.patch

Comment 11 Paul Moore 2014-05-29 20:40:49 UTC
Could you verify the above patch on your test system?  It works for me, but having another successful test is always nice.

Comment 13 Jaroslav Aster 2014-05-30 09:02:48 UTC
Hi Paul,

I tested it and it works. Thanks.

I reviewed the patch and I have one comment. strdup is ok, but there is still old comment above it and it does not make sense now.

/* need to malloc size of string plus null terminator */

Comment 14 Paul Moore 2014-05-30 13:12:13 UTC
The comment is still correct, the allocation and copy operations are just abstracted away in the strdup() call.  Regardless, I'll go ahead and remove the comment in the released package as I see how it could be confusing to some.

Expect a final build soon.

Comment 20 errata-xmlrpc 2014-06-09 06:56:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0639.html


Note You need to log in before you can comment on or make changes to this bug.