Bug 1098165 - UI: rotating spinner when selecting 'x' to remove installed packages.
Summary: UI: rotating spinner when selecting 'x' to remove installed packages.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-15 12:32 UTC by Sachin Ghai
Modified: 2019-09-26 17:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:07:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
see the rotating spinner along with 'zip' package (47.92 KB, image/png)
2014-05-15 12:32 UTC, Sachin Ghai
no flags Details
package removal on clicking 'x' works (42.12 KB, image/png)
2014-06-13 11:50 UTC, Sachin Ghai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 5974 0 None None None 2016-04-22 16:39:00 UTC

Description Sachin Ghai 2014-05-15 12:32:05 UTC
Created attachment 895883 [details]
see the rotating spinner along with 'zip' package

Description of problem:
I was trying to remove installed package from selected content host by clicking 'x' on UI. When I clicked on 'x', spinner starts rotating and keep on rotating.

I didn't see any exception/error neither in production.log nor on client under /var/log/gofer/agent.log 

Version-Release number of selected component (if applicable):
sat6 beta snap4:

Satellite-6.0.3-RHEL-6-20140508.1


* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.7-1.el6sat.noarch
* foreman-compute-1.6.0.7-1.el6sat.noarch
* foreman-gce-1.6.0.7-1.el6sat.noarch
* foreman-libvirt-1.6.0.7-1.el6sat.noarch
* foreman-ovirt-1.6.0.7-1.el6sat.noarch
* foreman-postgresql-1.6.0.7-1.el6sat.noarch
* foreman-proxy-1.6.0.4-1.el6sat.noarch
* foreman-selinux-1.5.0-0.develop.el6sat.noarch
* foreman-vmware-1.6.0.7-1.el6sat.noarch
* katello-1.5.0-22.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.37-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.1-0.4.beta.el6sat.noarch
* pulp-nodes-parent-2.3.1-0.4.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-selinux-2.3.1-0.4.beta.el6sat.noarch
* pulp-server-2.3.1-0.4.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.8-1.el6sat.noarch
* rubygem-hammer_cli-0.1.0-12.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.0-12.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.2-5.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.3-22.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. register a client with sat6 server
2. install tools (katello-agent) on client
3. start goferd
4. now go to sat6 server-->content-host -> registered system --> packages-> click on 'x' to remove selected package.

Actual results:

Expected results:
package should be removed and a link should generate that points to removed package status under 'tasks'


Additional info:

Comment 1 RHEL Program Management 2014-05-15 12:55:17 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Brad Buckingham 2014-05-28 20:01:55 UTC
Created redmine issue http://projects.theforeman.org/issues/5974 from this bug

Comment 5 Brad Buckingham 2014-06-09 20:43:30 UTC
fixed in katello PR: 
   https://github.com/Katello/katello/pull/4237

Comment 8 Sachin Ghai 2014-06-13 11:49:30 UTC
verified with sat6 beta snap9 compose 

on clicking 'x' to remove package, actually starts the package removal and successfully removes the selected package. thanks Brad.

Comment 9 Sachin Ghai 2014-06-13 11:50:16 UTC
Created attachment 908526 [details]
package removal on clicking 'x' works

Comment 10 Bryan Kearney 2014-07-02 14:07:02 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.