This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 109819 - vim-minimal should not depend on vim-common
vim-minimal should not depend on vim-common
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 21:42 EST by Rodolfo J. Paiz
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-13 18:04:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rodolfo J. Paiz 2003-11-11 21:42:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
vim-minimal takes up 460K roughly, and is nice and small. However, it 
depends on vim-common which is over 10MB, so there is no real savings 
in space there.

I can "rpm -i --nodeps vim-minimal-6.2.121-1.i386.rpm" and not have 
any problems; vim seems to work as expected. Can the dependency on 
vim-common be eliminated somehow?

Version-Release number of selected component (if applicable):
vim-minimal-6.2.121-1

How reproducible:
Always

Steps to Reproduce:
1.rpm -ivh vim-minimal-6.2.121-1.i386.rpm fails, noting a dependency 
on vim-common-6.2.121-1.i386.rpm.

2. rpm -ivh --nodeps vim-minimal-6.2.121-1.i386.rpm succeeds.

Actual Results:  vim-minimal appears to function well when installed 
with --nodeps and without vim-common.

Expected Results:  vim-minimal should not require vim-common as a 
dependency. With an extra 10MB installed, it is no longer "minimal" 
in any way.

Additional info:

I am sure that there is some valid reason that some code is in vim-
common to avoid duplication with vim-enhanced, and that this is not a 
mistake of any kind. However, it really does cause a problem 
sometimes when one wants to install a "minimal" package of 460K and 
one gets a 10MB dependency. Eliminating this dependency would be 
absolutely wonderful for smaller systems where those 10MB matter.
Comment 1 Karsten Hopp 2003-11-13 18:04:23 EST
I've removed the dependency and added a hint to the package 
description that the online help will only be available when 
vim-common is installed. Please test the rawhide package 
vim-*-154-1* (without vim-common installed) and report any problems 
caused by the missing /usr/share/vim/ files. 
Comment 2 Bret Hughes 2003-11-13 18:56:39 EST
I guess I am too ignorant to find this.  Wher is there a rawhide for
fedora?  if I go to rawhide.redhat.com and drill into it I can find
nothing that says fedora.   If I drill into download.fedora.redhat.com
I can't find anything that says rawhide?

Help me out please.

Bret
Comment 3 Karsten Hopp 2003-11-13 19:29:33 EST
I think the URL is 
ftp://download.fedora.redhat.com/pub/fedora/linux/core/development/, 
but it may take a while until the new packages show up there. 
I've put the packages on http://people.redhat.com/karsten/ for 
immediate download. 
Comment 4 Rodolfo J. Paiz 2004-04-11 23:51:16 EDT
It has now been approximately five months since this bug was fixed and
closed, but the newer package has not yet made it into the released
updates. Is there a reason for that? Or is it because a deliberate
decision was made to let this update go until FC2?

Thanks.

Note You need to log in before you can comment on or make changes to this bug.