Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1098218 - Application Installer Continued
Application Installer Continued
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Petr Bokoc
ChangeAcceptedF21 SystemWideChange
:
Depends On: 1098735
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-15 09:48 EDT by Jaroslav Reznik
Modified: 2014-12-08 10:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
<title>GNOME Software</title> <para> The <application>GNOME Software</application> application installer (the <package>gnome-software</package> package), which was first introduced in Fedora 20, is now more integrated in the system and provides additional functionality. Notable new features include: </para> <itemizedlist> <listitem> <para> Installing application add-ons is now supported. </para> </listitem> <listitem> <para> High quality metadata, such as screenshots, are now offered with many applications, allowing you to gather more information before installing a package. </para> </listitem> <listitem> <para> The installer has been turned into a session service, which allows it to check for available system updates automatically even when the application itself has not been launched by the user. This functionality was previously provided by the <systemitem>gnome-settings-daemon</systemitem> service. </para> </listitem> <listitem> <para> The application is now much better integrated into <application>GNOME Shell</application>: </para> <itemizedlist> <listitem> <para> Available system updates are now offered in the <guilabel>Power Off</guilabel> dialog. </para> </listitem> <listitem> <para> Non-installed packages can now be displayed among search results when using the integrated search function. </para> </listitem> <listitem> <para> You can now right-click an application icon in the shell overview and select <guimenuitem>Show Details</guimenuitem> from the menu to obtain information about the application. </para> </listitem> </itemizedlist> </listitem> <listitem> <para> You can now create and customize application folders using the application installer. </para> </listitem> <listitem> <para> The tool now starts up much faster and provides a more responsive interface due to the switch from the YUM backend to the one provided by the DNF project. </para> </listitem> </itemizedlist> <para> See the <ulink url="http://fedoraproject.org/wiki/Changes/AppInstallerContinued">Application Installer Continued</ulink> wiki page for more information. </para>
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 10:22:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pbokoc: fedora_requires_release_note+


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2014-05-15 09:48:20 EDT
This is a tracking bug for Change: Application Installer Continued
For more details, see: https://fedoraproject.org//wiki/Changes/AppInstallerContinued

Fully integrate the new application installer with Fedora, and complete its feature set
Comment 1 Jaroslav Reznik 2014-07-04 06:43:32 EDT
This message is a reminder that Fedora 21 Accepted Changes Freeze Deadline is on 2014-07-08 [1].

At this point, all accepted Changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Freeze.

This bug should be set to the MODIFIED state to indicate that it achieved completeness. Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution. For Changes you decide to cancel/move to the next release, please use the NEW status and set needinfo on me and it will be acted upon. 

In case of any questions, don't hesitate to ask Wrangler (jreznik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/21/Schedule
Comment 2 Petr Bokoc 2014-08-11 14:29:24 EDT
Hi Richard and Kalev,

I wrote a beat about this change for Fedora 21 Release Notes. Please review the text at https://fedoraproject.org/wiki/Documentation_Desktop_Beat (the "GNOME Software" section), and tell me if it is correct and complete, or if you want to change or add anything.

Thanks you!
Petr
Comment 3 Kalev Lember 2014-08-11 14:48:25 EDT
Hi Petr,

Thanks for helping with the documentation, much appreciated! Looks like a great start, but I would change a few things:

1) "Documentation Desktop Beat" -- shouldn't it be now called Workstation?

2) "The GNOME Software application installer (the gnome-software package)" -- could maybe say something like "The Fedora Workstation application installer (gnome-software)" ?

3) I wouldn't go into mentioning technical details like the hawkey library, "The hawkey library is now used to query and resolve package dependencies.", but instead say that it now starts up much faster and provides a more responsive interface due to the switch from the yum backend to the one provided by the dnf project

4) I'd mention better integration with the desktop shell -- updates offered in the shutdown dialog, GNOME Shell search provider that returns results for apps that aren't installed, ability to right-click on apps in the shell overview and select "Show Details"

5) And last but not least -- a LOT MORE APPS now ship screenshots and high quality metadata
Comment 4 Petr Bokoc 2014-08-11 17:16:41 EDT
Thank you for the quick reply, Kalev.

1) That's really just a category name. We'd prefer to keep GNOME-related content here, because while Workstation is the only product that ships a GUI by default, if I understand it correctly there will still be spins, and we don't want to imply that you can only get Software (or GNOME in general) if you install Workstation. However, we have a separate category for Workstation-specific content, so I think we can add a link there, pointing to this text in the Desktop section.

2) That's related to the above. Since spins will continue to exist, we'd prefer to call this "GNOME Software" instead of tying the name to Fedora Workstation.

3), 4) and 5) have been addressed.

https://fedoraproject.org/wiki/Documentation_Desktop_Beat#GNOME_Software
Comment 5 Kalev Lember 2014-08-12 03:38:20 EDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.