This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 109831 - No support for sysfs and some more optimizations
No support for sysfs and some more optimizations
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 02:02 EST by Ulrich Drepper
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.44-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 01:27:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to mount sysfs (4.96 KB, patch)
2003-11-12 02:03 EST, Ulrich Drepper
no flags Details | Diff

  None (edit)
Description Ulrich Drepper 2003-11-12 02:02:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b)
Gecko/20031111 Firebird/0.7+

Description of problem:
The initscripts should treat sysfs like procfs and mount it early. 
I'll attach a patch for this which is a bit more complicated than
needed since it actually creates the /sys mount point if necessary. 
The patch also adds some more optimizations I stumbled across.

Version-Release number of selected component (if applicable):
initscripts-7.42-1

How reproducible:
Always

Steps to Reproduce:
1.boot 2.6 kernel
2.look for sysfs under /sys
3.
    

Actual Results:  Not there

Expected Results:  sysfs moutned

Additional info:
Comment 1 Ulrich Drepper 2003-11-12 02:03:07 EST
Created attachment 95920 [details]
Patch to mount sysfs
Comment 2 Bill Nottingham 2004-01-28 01:27:17 EST
sysfs mounting added in CVS, will be in 7.44-1.

Note You need to log in before you can comment on or make changes to this bug.