Bug 1098418 - updating the host collection limit below to already added content-host should throw a validation error
Summary: updating the host collection limit below to already added content-host should...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-16 07:04 UTC by Sachin Ghai
Modified: 2019-09-26 17:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:06:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
see the limit for 'sghai_hosts', it already have 2 content-hosts and limit is set to '1' (23.94 KB, image/png)
2014-05-16 07:04 UTC, Sachin Ghai
no flags Details
proper validation error raised by UI. (46.21 KB, image/png)
2014-05-29 09:02 UTC, Sachin Ghai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 5801 0 None None None 2016-04-22 15:46:25 UTC

Description Sachin Ghai 2014-05-16 07:04:27 UTC
Created attachment 896215 [details]
see the limit for 'sghai_hosts', it already have 2 content-hosts and limit is set to '1'

Description of problem:
I've created a host collection with content-host limit 10. And I've successfully added two content host in the selected collection.

Later, when I tried to reduce the limit to '1' which is less than the already added number of hosts, it was correctly updated and notification says: Host collection updated.

But when I navigate away and come back on same page then found the system limit was still set to what it was originally i.e. 10 in this case.

So ideally, UI should throw a validation error if I set the limit below to already added host.


Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140508.1

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.7-1.el6sat.noarch
* foreman-compute-1.6.0.7-1.el6sat.noarch
* foreman-gce-1.6.0.7-1.el6sat.noarch
* foreman-libvirt-1.6.0.7-1.el6sat.noarch
* foreman-ovirt-1.6.0.7-1.el6sat.noarch
* foreman-postgresql-1.6.0.7-1.el6sat.noarch
* foreman-proxy-1.6.0.4-1.el6sat.noarch
* foreman-selinux-1.5.0-0.develop.el6sat.noarch
* foreman-vmware-1.6.0.7-1.el6sat.noarch
* katello-1.5.0-22.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.37-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.1-0.4.beta.el6sat.noarch
* pulp-nodes-parent-2.3.1-0.4.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-selinux-2.3.1-0.4.beta.el6sat.noarch
* pulp-server-2.3.1-0.4.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.8-1.el6sat.noarch
* rubygem-hammer_cli-0.1.0-12.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.0-12.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.2-5.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.3-22.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. create host collection with limit 10
2. added two content-host to create collection in step1
3. now update the collection limit to 1

Actual results:
limit was correctly updated and notification says: Host collection updated.
But when I navigate away and come back on same page then found the system limit was still set to what it was originally

Expected results:
UI should throw validation error.


Additional info:
no errors in production.log

Comment 1 RHEL Program Management 2014-05-16 07:25:31 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Brad Buckingham 2014-05-19 21:25:40 UTC
Created redmine issue http://projects.theforeman.org/issues/5801 from this bug

Comment 4 Brad Buckingham 2014-05-23 20:40:48 UTC
Katello PR:

https://github.com/Katello/katello/pull/4154

Comment 6 Sachin Ghai 2014-05-29 09:02:06 UTC
Verified with satellite6 beta snap7:

Now I can see following error if I set the limit below to already added content-hosts in selected host collection.

--
An error occurred saving the Host Collection: Validation failed: Content host limit may not be less than the number of content hosts associated with the host collection. 
--

Comment 7 Sachin Ghai 2014-05-29 09:02:49 UTC
Created attachment 900286 [details]
proper validation error raised by UI.

Comment 8 Bryan Kearney 2014-07-02 14:06:11 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.