Bug 1098473 - ipsec newhostkey returns 0 even if it fails and allows new RSA keys < 2048
ipsec newhostkey returns 0 even if it fails and allows new RSA keys < 2048
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openswan (Show other bugs)
6.5
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Paul Wouters
Aleš Mareček
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-16 06:07 EDT by Aleš Mareček
Modified: 2014-10-14 04:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:19:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleš Mareček 2014-05-16 06:07:32 EDT
Description of problem:
ipsec newhostkey returns 0 value even if it fails in generating keys of less bits than default (2192) and number indivisible by 16.

Version-Release number of selected component (if applicable):
openswan-2.6.32-27.el6, openswan-2.6.32-27.4.el6_5

How reproducible:
Always

Steps to Reproduce:
1. ipsec newhostkey --bits 1234 --output /etc/ipsec.secrets --random /dev/urandom ; echo $?


Actual results:
ipsec rsasigkey: bit count (1234) not multiple of 16
0

Expected results:
ipsec rsasigkey: bit count (1234) not multiple of 16
1

Additional info:
Comment 2 Paul Wouters 2014-05-16 09:21:57 EDT
this is fixed in libreswan already. I guess we can fix it in openswan too.
Comment 4 Paul Wouters 2014-07-22 13:48:29 EDT
Let's pull it in, as we're still a few days away from having a new build for rhel 6.6
Comment 7 errata-xmlrpc 2014-10-14 04:19:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1588.html

Note You need to log in before you can comment on or make changes to this bug.