Bug 1098477 - post install scripts failed rhel7
Summary: post install scripts failed rhel7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-16 10:26 UTC by Levente Farkas
Modified: 2014-10-10 16:04 UTC (History)
3 users (show)

Fixed In Version: mock-1.1.41-3.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-22 14:45:56 UTC


Attachments (Terms of Use)

Description Levente Farkas 2014-05-16 10:26:36 UTC
yum install mock
Loaded plugins: langpacks, product-id, subscription-manager
epel/x86_64/metalink                                                                                                                  |  19 kB  00:00:00     
epel                                                                                                                                  | 3.7 kB  00:00:00     
(1/2): epel/x86_64/group_gz                                                                                                           | 163 kB  00:00:00     
(2/2): epel/x86_64/primary_db                                                                                                         | 1.6 MB  00:00:10     
Resolving Dependencies
--> Running transaction check
---> Package mock.noarch 0:1.1.38-1.el7 will be installed
--> Processing Dependency: python-decoratortools for package: mock-1.1.38-1.el7.noarch
--> Processing Dependency: pigz for package: mock-1.1.38-1.el7.noarch
--> Running transaction check
---> Package pigz.x86_64 0:2.2.5-2.el7 will be installed
---> Package python-decoratortools.noarch 0:1.8-6.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================
 Package                                        Arch                            Version                                  Repository                     Size
=============================================================================================================================================================
Installing:
 mock                                           noarch                          1.1.38-1.el7                             epel                          218 k
Installing for dependencies:
 pigz                                           x86_64                          2.2.5-2.el7                              epel                           46 k
 python-decoratortools                          noarch                          1.8-6.el7                                epel                           29 k

Transaction Summary
=============================================================================================================================================================
Install  1 Package (+2 Dependent packages)

Total download size: 292 k
Installed size: 819 k
Is this ok [y/d/N]: y
Downloading packages:
(1/3): python-decoratortools-1.8-6.el7.noarch.rpm                                                                                     |  29 kB  00:00:00     
(2/3): pigz-2.2.5-2.el7.x86_64.rpm                                                                                                    |  46 kB  00:00:00     
(3/3): mock-1.1.38-1.el7.noarch.rpm                                                                                                   | 218 kB  00:00:00     
-------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                        460 kB/s | 292 kB  00:00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Installing : python-decoratortools-1.8-6.el7.noarch                                                                                                    1/3 
  Installing : pigz-2.2.5-2.el7.x86_64                                                                                                                   2/3 
  Installing : mock-1.1.38-1.el7.noarch                                                                                                                  3/3 
warning: %post(mock-1.1.38-1.el7.noarch) scriptlet failed, exit status 254
Non-fatal POSTIN scriptlet failure in rpm package mock-1.1.38-1.el7.noarch
  Verifying  : pigz-2.2.5-2.el7.x86_64                                                                                                                   1/3 
  Verifying  : python-decoratortools-1.8-6.el7.noarch                                                                                                    2/3 
  Verifying  : mock-1.1.38-1.el7.noarch                                                                                                                  3/3 

Installed:
  mock.noarch 0:1.1.38-1.el7                                                                                                                                 

Dependency Installed:
  pigz.x86_64 0:2.2.5-2.el7                                             python-decoratortools.noarch 0:1.8-6.el7                                            

Complete!

Comment 1 Levente Farkas 2014-05-16 10:28:19 UTC
ohh and the reason is that:
rpm -q --nosignature --qf "%{VERSION}" --whatprovides redhat-release
return 7.0 not 7

Comment 2 Miroslav Suchý 2014-05-16 11:35:22 UTC
Fixed in msuchy-work branch in commit 1494c39bf19e574d44bcc8fa1e69197c36d1627f

Comment 3 Michael Cronenworth 2014-05-22 14:45:56 UTC
@Miroslav, that commit will not fix this bug across all RHEL versions. Please see 1090073 for a patch that will.

*** This bug has been marked as a duplicate of bug 1090073 ***

Comment 4 Fedora Update System 2014-05-27 15:39:34 UTC
mock-1.1.39-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.39-1.fc19

Comment 5 Fedora Update System 2014-05-27 15:39:50 UTC
mock-1.1.39-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.39-1.el6

Comment 6 Fedora Update System 2014-05-27 15:40:06 UTC
mock-1.1.39-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.39-1.fc20

Comment 7 Fedora Update System 2014-06-01 22:23:05 UTC
mock-1.1.39-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-06-25 20:00:23 UTC
mock-1.1.39-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-07-18 02:13:32 UTC
mock-1.1.40-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.fc20

Comment 10 Fedora Update System 2014-07-18 02:13:57 UTC
mock-1.1.40-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.fc19

Comment 11 Fedora Update System 2014-07-18 02:14:20 UTC
mock-1.1.40-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.el6

Comment 12 Fedora Update System 2014-07-18 17:45:39 UTC
mock-1.1.41-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.fc20

Comment 13 Fedora Update System 2014-07-18 17:46:05 UTC
mock-1.1.41-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.fc19

Comment 14 Fedora Update System 2014-07-18 17:46:31 UTC
mock-1.1.41-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.el6

Comment 15 Fedora Update System 2014-07-20 03:24:50 UTC
mock-1.1.41-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2014-07-22 18:08:10 UTC
mock-1.1.41-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2014-09-16 16:47:08 UTC
mock-1.1.41-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-2.fc19

Comment 18 Fedora Update System 2014-09-30 09:00:24 UTC
mock-1.1.41-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-3.fc19

Comment 19 Fedora Update System 2014-10-10 16:04:34 UTC
mock-1.1.41-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.