Bug 109852 - dbmopen problem in new nmh version of slocal with maildelivery file
Summary: dbmopen problem in new nmh version of slocal with maildelivery file
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: nmh   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-12 13:18 UTC by J G Miller
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 09:36:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description J G Miller 2003-11-12 13:18:45 UTC
Description of problem:

slocal: unable to perform dbm_open on
/home/users/miller/apps/etc/Mail/.maildelivery: No such file or directory

even though

 ll /home/users/miller/apps/etc/Mail/.maildelivery

   8 -rw-------    1 miller   miller       5589 Nov  6 17:48
/home/users/miller/apps/etc/Mail/.maildelivery


Version-Release number of selected component (if applicable):

nmh-1.0.4-20

How reproducible:

Every time slocal is invoked, the error message is given.

Steps to Reproduce:

slocal is invoked with a script with the following parameters

           slocal -info "${msg_dir}" -maildelivery ${maildelivery} \
                  -suppressdup -user ${USER} < ${msg_dir}/${msg}
  
Actual results:

maildelivery.db does not get updated.

Removing the old maildelivery.db results in an empty maildelivery.db
file being created, but never updated.

Expected results:

slocal should read the maildelivery file without complaining and
update maildelivery.db.

Additional info:

Whilst using the previous version of slocal under Red Hat 9, slocal
was working as expected.  Now, after upgrading to Fedora Core 1, this
problem has appeared.  Therefore the problem has arisen due to a
change in slocal in the different versions.


Note You need to log in before you can comment on or make changes to this bug.