Bug 1098576
| Summary: | ModClusterService stop commands are always draining sessions | ||
|---|---|---|---|
| Product: | [JBoss] JBoss Enterprise Application Platform 6 | Reporter: | Aaron Ogburn <aogburn> |
| Component: | mod_cluster | Assignee: | Jean-frederic Clere <jclere> |
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Michal Karm Babacek <mbabacek> |
| Severity: | unspecified | Docs Contact: | Russell Dickenson <rdickens> |
| Priority: | unspecified | ||
| Version: | 6.2.0 | CC: | kkhan, mbabacek, smumford |
| Target Milestone: | ER6 | ||
| Target Release: | EAP 6.3.0 | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: |
In previous versions of JBoss EAP 6, using the `ModClusterService` stop or `stopContext` commands from the CLI interface failed to move a context to the STOPPED state after failing to drain the active sessions. This meant these commands were not viable for quickly stopping the context when desired (without draining). This issue has been resolved with an updated to the mod_cluster component.
|
Story Points: | --- |
| Clone Of: | Environment: | ||
| Last Closed: | 2014-06-28 15:44:55 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1101681, 1107551 | ||
| Bug Blocks: | |||
Fixed per MODCLUSTER-404 so we need a component upgrade Updating to mod_cluster-1.2.9.Final have fixed the issue. Verified in EAP 6.3.0.ER7 mod_cluster 1.2.8 - calling ./jboss-cli.sh --connect --controller=192.168.122.78:9999 --command="/subsystem=modcluster:stop()" does not stop the context, present sessions are being kept mod_cluster 1.2.9 - calling the aforementioned causes an immediate failover to another node This bug is shown as affecting and fixed in 6.3.0. Is this the case? It might not need a release note. It needs a release note it was reported by a customer against 6.2. |
Description of problem: Using the ModClusterService stop or stopContext commands via CLI always fails to move a context to the STOPPED state after failing to drain the active sessions. So these commands then aren't very useful for quickly stopping the context when desired if you can't do it without draining. Version-Release number of selected component (if applicable): 1.2.8.Final How reproducible: Always Steps to Reproduce: 1. Setup httpd/JBoss/mod_cluster and deploy a <distributable/> app on JBoss 2. Establish a session on this app 3. Call via cli: /subsystem=modcluster:stop() And note that modcluster will try to drain the sessions, fail to do that within time, and then not stop the context (leaving it in a disabled state on httpd) Actual results: Session draining strategy isn't honored so stop commands usually don't actually stop contexts Expected results: Session draining strategy is honored so stop commands can be useful