Bug 10989 - Initscripts no properly unmounting drives on reboot/halt
Initscripts no properly unmounting drives on reboot/halt
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-22 14:13 EDT by SB
Modified: 2014-03-16 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-17 18:44:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SB 2000-04-22 14:13:31 EDT
Ever since I installed the latest initscripts my system has been failing
to unmount my /root partition.  I've been looking at the problem for the
last two days completely baffled.  The /root partition is root's home
directory which appears to be a key ingredient to the problem.  While
shutting down, it fails three times to unmount the /root partition saying
it is in use which should not be the case.  Last night I was using a
windows machine and had three remote telnet connections to the linux
machine.  The windows machine crashed and had to be hard-booted which left
the processes from the logins still running on the linux machine.  When I
went to shut down the linux machine it had another unmounting problem, it
could not unmount /root or /home partitions, as it claimed both were in
use.  So it seems whatever partition contains the home directory of user
who is logged in at reboot or halt time is unable to be unmounted because
it is believed to be in use.  I have the latest kernel 2.3.99 installed
plus latest mount, net-tools. bash, util-linux, and initscripts installed,
and seeing as they were all installed around the same time I'm unsure which
is causing the problem.  I assume it must be initscripts because something
is obviously not being exited prior to unmounting leaving the partitions
in-use.  One thing to note though is that fsck is not called after reboot
and the partitions always seem to be clean even after being checked so I'm
not even sure if they are not really being unmounted or what. This is what
the error looks like:

Unmounting file systems umount2: Device or resource busy
umount: /root: device is busy
                                                           [FAILED]
Unmounting file systems (retry) umount2: Device or resource busy
umount: /root: device is busy
                                                           [FAILED]
Unmounting file systems (retry) umount2: Device or resource busy
umount: /root: device is busy
                                                           [FAILED]

Any thoughts? Questions? Help?! :)

-Stan Bubrouski
Comment 1 Bill Nottingham 2000-06-17 18:18:03 EDT
Does this persist with later or earlier kernels? There were some refcounting
problems somewhere in 2.3.99, IIRC.
Comment 2 SB 2000-06-17 18:44:25 EDT
It's fixed in 2.4.0-test1 kernel, I'm not sure what kernel
version between 2.3.99-pre5 and 2.4.0-test1 fixed it though,
but either way my drives unmount properly now.

-Stan Bubrouski

Note You need to log in before you can comment on or make changes to this bug.