Bug 109897 - Animated mouse cursors are just outlines
Animated mouse cursors are just outlines
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 14:31 EST by Ulrich Drepper
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.3.0-58
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-23 00:45:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Part of screenshot showing the problem cursor (1.30 KB, image/jpeg)
2003-11-12 14:32 EST, Ulrich Drepper
no flags Details
My XFree config (3.82 KB, text/plain)
2003-11-12 14:33 EST, Ulrich Drepper
no flags Details

  None (edit)
Description Ulrich Drepper 2003-11-12 14:31:25 EST
Description of problem:

This started some time during the late FC1 development.  I did not
take it too serious since I at first observed it only when opening
windows from my test box.  But since I've updated my main box to FC1
it is visible for all windows.  To summarize: even with a RHL9 X
server and remote FC1 X applications the problem is visible.

Now to the problem itself.  No animated cursor is shown as such. 
Normal cursors work but when an animated cursor is selected the
appearence changes to an ugly outline.  No animation, the same outline
all the time.  Once the application changes the cursor back all is
fine again, the non-animated cursors displays fine.  I'll attach a
part of a screenshot to show the effect.

The distinguishing factor between my setup and that of most others is
that I'm using Xinerama on two separate Radeon 7500 cards.  Each card
drives one head.  I'll attach my config file as well.


Version-Release number of selected component (if applicable):


How reproducible:

All the time


Steps to Reproduce:
1. get Xinerama setup, with two cards, maybe even two Radeon 7500
2. start application which uses mouse cursors which can change to
   any of the animated cursors.  E.g., up2date.
3.
  
Actual results:
ugly outline mouse cursor

Expected results:
animated cursor

Additional info:
Comment 1 Ulrich Drepper 2003-11-12 14:32:57 EST
Created attachment 95928 [details]
Part of screenshot showing the problem cursor

I took the picture with a web cam since with the screenshot apps the cursor
doesn't appear in the picture.	It's not very sharp but you get the idea.
Comment 2 Ulrich Drepper 2003-11-12 14:34:00 EST
Created attachment 95929 [details]
My XFree config
Comment 3 Mike A. Harris 2003-11-13 04:07:40 EST
I haven't seen this at all personally, and haven't had anyone
else report the problem that I'm aware of.  Not sure what would
cause this other than mouse cursors with bad cursor images or
bad alpha channel.

Adding Keith Packard to see if he has seen this or has any ideas
what the problem could be.
Comment 4 Ulrich Drepper 2003-11-13 04:36:16 EST
I can add a few more details.

The test machine I mentioned has an NVidia card (not using the
proprietary driver).  Using the X display of that machine I see the
animated mouse cursors just fine.  Displaying the windows via ssh on
the xinerama/radeon machine shows the problem.

So the problem needs both, a locally updated X version (post RHL9) and
something related to the display hardware (Radeon) and/or software
(xinerama) I'm using.
Comment 5 Scott Phipps 2003-12-03 12:20:09 EST
I too have this on a machine with a readeon 7500.  It is exactly the
same as the cursors did when I had to disable the animeated cursors in
redhat 9 with Xinerama to prevent the hang related to Xinerama and the
radeon driver.  I did a fresh install of Fedora Core, however, so
there is no loeft over config.  The problem dosen't bother me, but I
thought I would chime in that I too have seen it.
Comment 6 Scott Phipps 2003-12-18 21:56:24 EST
I just replace the libXrender that came with fedora with the one from
redhat 9 to fix the problem with Xinerama and qt, and found that it
also fixes this bug.  So the problem is Xinerama and libXrender.
Comment 7 Scott Phipps 2003-12-18 22:00:07 EST
Sorry, meant to include that bug number.  Bug 109351 was the one I was
fixing when I discovered this.
Comment 8 Ulrich Drepper 2004-02-23 00:32:11 EST
The problem seems to be cured in XFree86-4.3.0-59.  I see animated
cursors again after installing this version and restarting the system.
Comment 9 Mike A. Harris 2004-02-23 00:45:20 EST
Ok, this indeed looks to have been a bug in libXrender.  I upgraded
libXrender to 0.8.4 in 4.3.0-58, which fixes the bug with Xinerama
and Qt that you've (Scott) mentioned above.  Since you indicate
the older libXrender also works around the problem, I think it's
safe to conclude that the problem was a Xinerama/libXrender
combination problem.  A bit odd that it hasn't been reported by
more people, but it's nice to see it fixed now.  I'll update
the changelog to indicate this bug was fixed also.  If the problem
recurs, please reopen.

Thanks.


* Wed Feb 18 2004 Mike A. Harris <mharris@redhat.com> 4.3.0-58
...
- Updated libXrender to the version 0.8.4 maintenance release, which
fixes a
  problem in 0.8.3 that caused antialiased fonts to be inadvertently
disabled
  in KDE (#109351)
Comment 10 John Flanagan 2004-05-12 00:19:48 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-118.html

Note You need to log in before you can comment on or make changes to this bug.