Bug 1099026 - ifup-eth arping fail should output responding MAC
Summary: ifup-eth arping fail should output responding MAC
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.5
Hardware: All
OS: Linux
high
low
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1270825 1322780
TreeView+ depends on / blocked
 
Reported: 2014-05-19 10:44 UTC by Jeremy Harris
Modified: 2016-11-25 12:58 UTC (History)
4 users (show)

Fixed In Version: initscripts-9.03.50-1.el6
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1322780 (view as bug list)
Environment:
Last Closed: 2016-05-11 01:05:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0951 0 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2016-05-10 22:56:20 UTC

Description Jeremy Harris 2014-05-19 10:44:36 UTC
Description of problem:

  The whinge message when the arping check fails a Duplicate Address Detect
gives the IP involved but not the MAC of the responder.  It would aid the
admin if this information was output.


Version-Release number of selected component (if applicable):

  RHEL-6/initscripts/9.03.40/2.el6_5.1/initscripts-9.03.40/sysconfig/network-scripts/ifup-eth#244

How reproducible:

  Always

Steps to Reproduce:
1. Set up two systems with a single IP
2. Bring up interface
3.

Actual results:
  "Error, some other host already uses address 10.105.50.58."


Expected results:
  Anything giving the responding MAC as well.  Plain output from arping might
suffice (it is currently run with a silencing switch; perhaps remove this and
divert the output to a variable for use in the fail-case).  Possibly some
massaging of the output would be needed.


Additional info:

Comment 1 Lukáš Nykrýn 2014-05-19 10:49:35 UTC
Sounds reasonable.

Comment 8 errata-xmlrpc 2016-05-11 01:05:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0951.html


Note You need to log in before you can comment on or make changes to this bug.